# IGSS 13 Configuration Workshop - Exercises

## Contents

<table>
<thead>
<tr>
<th>Exercise</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>IGSS 13 Configuration Workshop - Exercises</td>
<td>1</td>
</tr>
<tr>
<td>Exercise 1: Working as an Operator in IGSS</td>
<td>2</td>
</tr>
<tr>
<td>Exercise 2: Creating a new IGSS Project</td>
<td>28</td>
</tr>
<tr>
<td>Exercise 3: Create Areas and Diagrams in Definition</td>
<td>33</td>
</tr>
<tr>
<td>Exercise 4: Creating IGSS Objects on the Process Diagram</td>
<td>36</td>
</tr>
<tr>
<td>Exercise 5: Create Templates and Template Based Objects</td>
<td>57</td>
</tr>
<tr>
<td>Exercise 6: Create and Show Events</td>
<td>72</td>
</tr>
<tr>
<td>Exercise 7: Create a Graph time plot</td>
<td>77</td>
</tr>
<tr>
<td>Exercise 8: Create a Report Format and Generate a Periodical Report</td>
<td>87</td>
</tr>
<tr>
<td>Exercise 9: Use Standard Descriptors and Drawing toolbar</td>
<td>91</td>
</tr>
<tr>
<td>Exercise 10: Create and deploy Faceplates</td>
<td>106</td>
</tr>
<tr>
<td>Exercise 11: Using Notifier</td>
<td>137</td>
</tr>
<tr>
<td>Exercise 12: Create Users &amp; User Privileges; Lock project</td>
<td>143</td>
</tr>
<tr>
<td>Exercise 13: Create Maintenance Jobs</td>
<td>162</td>
</tr>
</tbody>
</table>
Exercise 1: Working as an Operator in IGSS

Contents
We want to see how a completed IGSS SCADA system appears to plant operator personnel to get an idea of the various elements in the system and how they work. Therefore, in the following, we assume the role of an operator and perform monitoring and control tasks.

Duration
30 - 45 minutes.

Start the Demo Project

Purpose
The IGSS project we will be using is the Demo project which is installed automatically when the “Demo system” option is selected during installation of IGSS.

Task 1:
Load and start the Demo project
The Demo project will be the foundation for the next few exercises until you will be creating your own project and populating it with objects, diagrams and elements of your own.

Now let’s go online with the Demo project.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Start IGSS from the <strong>Start</strong> menu in Windows or click the IGSS icon on the Windows desktop. The IGSS Master opens.</td>
</tr>
<tr>
<td>2.</td>
<td>In the IGSS Master’s <strong>Home</strong> tab, click the <strong>Start</strong> button.</td>
</tr>
<tr>
<td>3.</td>
<td>Click the <strong>Supervise</strong> button to activate the <strong>Supervise</strong> module.</td>
</tr>
</tbody>
</table>
Online in Supervise mode

To learn how to monitor and control different types of IGSS objects.

We need to locate the Flow tank 1 object (the q3 object) which is located somewhere in the plant process diagram but we don’t know exactly where.

The Flow tank 1 object is also named q3 in the system. Flow tank 1 is the object description and q3 is the object name.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Locating the object. In the Supervise menu, click Edit &gt; Open by Name to open the Object Browser form.</td>
</tr>
<tr>
<td>2.</td>
<td>Locate by object name</td>
</tr>
<tr>
<td></td>
<td>Find the objects with names beginning with “q”</td>
</tr>
<tr>
<td>a)</td>
<td>At the bottom of the Object Browser form, select the Advanced check box to expand the form with additional fields.</td>
</tr>
<tr>
<td>b)</td>
<td>Under the right pane, in the Wild card text criteria field, enter “q*” as search criterion.</td>
</tr>
<tr>
<td>c)</td>
<td>Select the Match Case check box</td>
</tr>
<tr>
<td>d)</td>
<td>Select the Search in name check box</td>
</tr>
<tr>
<td>e)</td>
<td>Clear the Search in description check box</td>
</tr>
</tbody>
</table>
Exercise 1: Working as an Operator in IGSS

All objects starting with the letter q are displayed in a list in the right hand pane of the form.

![Image of Object Browser form]

3. You can also locate the object by using the object description.
   a) At the bottom of the Object Browser form, select the Advanced check box to expand the form with additional fields.
   b) Under the right pane, in the Wild card text criteria field, enter “Flow*” as search criterion.
   c) Select the Match Case check box
   d) Clear the Search in name check box
   e) Select the Search in description check box

All objects starting with the letters Flow are displayed in a list in the right hand pane of the form.
4. In the list, select the **q3 – Flow tank 1** object.

In the **Open by name** group, clear the **Show properties** check box, select the **Go to diagram** check box and click the **Open/Select** button.

The diagram where the q3 object is located is opened and the object is displayed with an animated line around it.

5. Right-click on the **q3** object (the ◊ under the tank) to bring up the **Object Properties** form and select the **Analog** tab (see screen print next page).

Change the **High Alarm** setting to “80” and click the **OK** button.
Exercise 1: Working as an Operator in IGSS

Click the q3 object again to see the result of your change.

6. Right-click the q3 object ◊ and select Properties to open the q3 properties form. Click the Analog tab and change the High Alarm value to the original setting of 88. Click the OK button to finish.

Task 2: Send commands (digital object)

You now need to stop the pump (p1) in the process diagram. You do this by locating the pump in the process diagram first and then send the STOP command to the pump through the p1 object.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Find the object p1 in the same way you found the q3 object (e.g. step 3).</td>
</tr>
<tr>
<td>2.</td>
<td>Select the P1 object from the list in the Object Browser, and click Select/Open. The Refuse disposal plant process diagram will now open.</td>
</tr>
</tbody>
</table>
2. In the Refuse disposal plant process diagram you can send the STOP command in the following ways:

- Click the STOP button under the p1 text
- Right-click the p1 object and select STOP.
- Right-click the p1 object and select Properties.
  - Click the Digital tab and select STOP in the Commands field.

Close the Refuse disposal plant process diagram by clicking the back button in the top right corner.
Alarm Handling

Purpose
To learn how to:

- Acknowledge alarms in both the Active Alarms list and on the object name in the process diagram.
- Find objects in the process diagram, which are in a state of alarm.
- Create alarm list filters
- Customize the alarm list

Task 1: Acknowledge alarms
First you need to find and acknowledge the presently occurring alarms in the demo project by opening the alarm list in the Active Alarms form.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Training Diagram Overview, select the Dairy Production process diagram.</td>
</tr>
<tr>
<td>2.</td>
<td>Find the object q2 – Flow Outlet and acknowledge its alarm. This can be done in five different ways:</td>
</tr>
<tr>
<td></td>
<td>1) In the process diagram: Right-click the object name or object symbol to bring up the command menu, then left click and select Acknowledge Alarm</td>
</tr>
<tr>
<td></td>
<td>2) From the Alarm List in the Active Alarms form:</td>
</tr>
<tr>
<td></td>
<td>a. Double-click on the square alarm icon on the process diagram</td>
</tr>
<tr>
<td></td>
<td>b. Find the object, right-click on it, right-click again on “Acknowledge”</td>
</tr>
</tbody>
</table>
3) Open the Alarm List in the **Active Alarms** form by clicking on **Active Alarms** in the Windows task bar at the bottom of the screen and follow procedure in (2) above.

4) Open the Alarm List by clicking on the small square shaped icon ( ) on the system tray at the bottom right hand corner of the screen and follow procedure in (2) above.

5) Open the Alarm List from the **IGSS Master**, click **Home** tab > **Alarm** button and follow procedure in (2) above.

There are many alarms in the alarm list and we need to filter the alarms to display the alarms we have an interest in monitoring. Right now we want to filter alarm list to display all objects that start with “q”.

### Task 2:
Create a new alarm list filter

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
</table>
| 1.   | Open the **Active Alarms** form e.g. by clicking the **Active Alarms** icon in the Windows task bar (method 3 above).  
**Tip:** If the left pane of the Active Alarm form is hidden, you can expand the pane by selecting it with the mouse cursor and dragging the pane to the right. |
2. In the tree view, select the Active Alarms folder. On the Active Alarms menu, click Customize > New Filter to create a filter (if New Filter cannot be selected, select Active Events and the Active Alarms).

- In the Filter name field, enter “Flow Gauges”.
- In the Property field, select “Object name”
- In the Condition field, select “begins with”
- In the Value field, enter “q”

Click the Add button to add the new filter.

Click the OK button to create the Flow gauges filter and place it under the Active Alarms folder in the left pane.

3. Click the Flow Gauges filter to see the filter’s results in the list pane to the right.
Task 3: Customize the alarm list

You can also customize the alarm list that is displayed in the right pane, selecting which columns are to be displayed and their sorting order in order to increase the overview granted by the alarm list.

We need to display the following information in the alarm list:

- S.No.
- Area name
- Object name
- Description
- Alarm number
- Alarm text
- Priority
- Value
- Start date
- End date
- Acknowledge time

We are not interested in the rest of the columns in the alarm list and should remove them from the alarm list.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Select the <strong>Flow gauges</strong> filter under the <strong>Active Alarms</strong> folder in the left pane of the <strong>Active Alarms</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>Click the right pane of the <strong>Active alarm list</strong> to bring the alarm list into focus.</td>
</tr>
<tr>
<td>3.</td>
<td>Click <strong>Customize &gt; Alarm List Format</strong> to open the <strong>Alarm List format</strong> form.</td>
</tr>
<tr>
<td>4.</td>
<td>In the <strong>All Columns</strong> group, select <strong>Object Name</strong> and click the <strong>Add</strong> button to add the <strong>Object Name</strong> to the alarm list display.</td>
</tr>
<tr>
<td>5.</td>
<td>Repeat step 3, adding <strong>Value</strong> to the alarm list display.</td>
</tr>
</tbody>
</table>
6. In the **Columns Displayed** group, select **Start time** and click the **Remove** button to remove the **Start time** from the alarm list display.

7. Repeat step 6 until you have only have the 11 columns displayed you want.

8. Move the columns up or down by selecting the column you want to re-arrange and clicking the **Move Up** or **Move Down** buttons.

9. Click the **OK** button to save the column display and return to the Alarm list.

10. Select the **Flow gauges** filter under the **Active Alarms** folder in the left pane of the **Active Alarms** form.

11. Click the right pane of the **Active alarm** list to bring the alarm list into focus.

12. Click **Customize > Set Sort Order** to open the **Set Sort Order** form.

13. In the **Sort** group, select the object and the **Move Up** or **Move Down** button to create the sort order below:
   
   1. **Priority**
   2. **Area Name**
   3. **Object Name**

   ![Set Sort Order Form](image)

14. In the **Sort** group, select

   - **Priority** and select the **Descending** option
   - **Area Name** and select the **Ascending** option
   - **Object Name** and select the **Ascending** option

15. Click the **OK** button to return to the alarm list.
Try changing the sort order and the ascending/descending sort direction for other columns to see what happens.

Note that all columns are listed in the Set Sort Order form, even the columns that are not to be displayed.

Try changing the sort order of some of the columns not displayed.

---

**Task 4:** Inhibit alarms and alarm note

You can also inhibit objects from triggering an alarm, suppressing the alarms generated by that object as well as adding an alarm note to the object alarm.

Alarms notes are used to inform others as well as yourself of events and important information concerning the active alarm.

We are going to inhibit the alarm of the **q1 – Flow water in** object and insert an alarm note that explains who inhibited the alarm and when. You can inhibit an alarm on an object by right-clicking on the object in alarm list or on the object itself in the Supervise process diagram.

First, we have to locate the **q1 – Flow water in** object though. The object name is **q1** and the object description is **Flow water in**.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1.</strong></td>
<td>Click <strong>IGSS Master &gt; Home &gt; Supervise</strong> to open the Supervise module</td>
</tr>
</tbody>
</table>
| **2.** | Locate the object **q1 Flow water in**:
In the **Supervise** menu, click **Edit > Open by Name** to open the **Object Browser** form. Insert q1* under **Wild text criteria**, select **Match case, Search in name** and **Search in description**. You can locate the object by object name (**q1**) or object description (**Flow water in**).
Select **q1 Flow water in** from the list in the right pane and click **Open /Select**, which will open the **Object browser** form. Click OK to close the form. |
| **3.** | The **Dairy** diagram where the **q1** object is located is opened and the object is displayed with an animated line around.
Right-click the **q1** object (the ◊ under the top left tank) in the diagram and select **Inhibit alarms...** to open the **Inhibit Alarms** form. |
In the Inhibit Alarms form:

1. Select the Inhibit only individual alarms on the object as selected below check box.
2. In the pane below, select the 212: High alarm level exceeded check box only.
3. Leave all other alarm check boxes cleared.
4. Click the OK button.

You have just inhibited the one of the alarms on the q1 object.

**Note**
You can also locate the object directly through the Alarm List in the right pane of the Active Alarms form by right-clicking on the object in the Alarm List and selecting Find.
Exercise 1: Working as an Operator in IGSS

5. Find q1 in the Alarm List in the right pane of the Active Alarms form and find the inhibited alarm for the q1 object.

Hint: The system alarm for an alarm inhibition is alarm number 92 with the alarm text Alarm Inhibit (specific alarms).

6. Right-click on q1 in the Alarm List and select Note... to open the Alarm Text/Alarm Note form.

Click on the Alarm Note tab and in the input field (the white field underneath the dimmed Description field) enter “I inhibited this alarm <your initials><date>.”

Click the OK button and verify that the note icon ( ) is displayed to the left of the q1 object line in the alarm list.

Task 5: Create Object Note

In addition to attaching a note to the alarm on an object, we can create and attach a note on the object, registering important information regarding the object independently of any occurring alarms.

An object note is to be created on the q4 – Flow tank 4 object, where q4 is the object name and Flow tank 4 is the object description.
### Exercise 1: Working as an Operator in IGSS

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Open the <strong>Active Alarms</strong> form e.g. by clicking the <strong>Active Alarms</strong> icon in the Windows task bar.</td>
</tr>
<tr>
<td>2.</td>
<td>Locate the <em>q4</em> object in the Alarm List under <strong>Edit &gt; Search...</strong> or <strong>Ctrl + F</strong></td>
</tr>
<tr>
<td>3.</td>
<td>Right-click the <em>q4</em> object in the <strong>Active Alarms</strong> list and select <strong>Note...</strong>. Click the <strong>Alarm Note</strong> tab and under the <strong>Description</strong> field enter the message “I have a message about this object for operators on duty.” and click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>
| 4.   | In the Alarm List in the right pane, find the *q4* object and observe how it looks.  
- Verify that the note icon (ן) is displayed to the left of the *q4* object  
- What alarm number does the alarm have? |

**Tip:**
You can also add an alarm note to an object from the diagram. Right-click the object and select **Object Note**. In the **Object Properties** form’s **Object Note** tab enter the message in the blank field under “By user”. You can also Acknowledge or Terminate the alarm in this form (screen print in the next exercise step 3).

**Note**
The alarm text and font colors are set up in the **Definition** module in the **Alarm Details** form found in **Edit > Alarm Texts**. Creating new alarm texts and editing existing alarm texts are detailed later.
Task 6: Remove Object Note

We now have to remove the object note from the q4 – Flow tank 4 object and see what happens to the alarm list and the alarm log.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Active Alarms form, locate the q4 – Flow tank 4 object in the Alarm List in the right pane of the Active Alarms form. Note the alarm number of the alarm line with the q4 object note. (hint: The Alarm number is 96 and the alarm text is “Object note attached”</td>
</tr>
<tr>
<td>2.</td>
<td>In the Alarm List, right-click the q4 object and select Find.</td>
</tr>
<tr>
<td>3.</td>
<td>The Dairy process diagram is opened in Supervise and the q4 – Flow tank object is marked with an animated symbol. Right-click the q4 object and select Object note. In the Edit Object note tab, click the Terminate button. The note text in the input field under the By user field is cleared. Click the OK button.</td>
</tr>
</tbody>
</table>
4. Open the **Active Alarms** list and find the *q4* object again. Verify that the alarm for the *q4* object list with the object note icon is no longer displayed in the alarm list in the right pane of the **Active Alarms** form.

5. In the left pane, click the **Alarm Log** folder (even if it is preselected) and create a **New Filter** to locate the *q4* object the same way you did in Task 2, step 2.

   ![New Filter](image)

   Click **Customize > New Filter** to create a filter*:  
   - In the **Filter name** field, enter “Flow Gauges”.
   - In the **Property** field, select “Object name”
   - In the **Condition** field, select “begins with”
   - In the **Value** field, enter “q4”

   Click the **Add** button to add the new filter.

   * If New Filter cannot be selected, select Active Events and the Active Alarms.

6. In the alarm list in the right pane of the Alarm logs, use the alarm number (96) from step 1 above and find the alarm line that was created when you attached an object note to the *q4* object. Here you can see that the alarm note icon is still visible.

   **Tip**
   You can sort the entries in the Alarm List by clicking on the header of the column in the Alarm List. You can also create a new sort order for the filter if you want.
Exercise 1: Working as an Operator in IGSS

Working with Graphs

Purpose

Learn how to:

- Open and work with a pre-defined stand-alone Window graph
- Work with and save operator graph (dynamic) based on embedded graph
- Create a new operator graph

Task 1:
Open and navigate a Stand-alone graph

You can view the data which your objects in the Supervise process diagram collect during operations through graphs. There are different types:

- **Pre-defined graphs** that can only be created, defined, edited and deleted by the system designer in the Definition module and made available to operators. They come in 2 forms:
  - Embedded graph shown in a process diagram e.g. as part of a specific descriptor or object (cannot be saved as Operator Graph).
  - Stand-alone Window graph shown in a separate window, not inside a diagram (can be edited and saved as Operator Graph)

- **Operator graphs**: Created in the Supervise module by the operator either from scratch or on the basis of a pre-defined graph.

First, we will open and view a graph in a window. Then you can create your own operator graph, first based on an embedded graph and then from scratch. The graphs used in this exercise have been created for the demo project.

You will create pre-defined graphs in the Definition module later in exercise 7.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
</table>
| 1. | In IGSS Master > Home tab, click the Start button to start the demo. Click the Supervise button to open the demo diagram. In the Supervise menu:  
  - Click Area > Cases (or in the Introducing IGSS diagram, click Project Examples)  
  - Click Graph and open the Water Supply Total Extractions graph: |
### Exercise 1: Working as an Operator in IGSS

#### 2. Navigate the graph – X-axis

Navigate the X-axis (Time axis) left and right using the **Left and Right arrow keys** `< →` on your keyboard. Each arrow key increments the graph period by a fixed segment (minutes, hours, days, depending on the segmentation of the X-axis).

You can also left-click the X-axis with the mouse and drag it left and right, or right-click the X-axis and select:

- **Go Backward**: Move X-axis a specific period back
- **Go to Date**: Move the X-axis to a specific date
- **Go to Now**: Move the X-axis to the present date and time.
- **Change Period**: Change the display period of the entire graph

You can also use the **Go to Date**, **Change Period** and **Compare Periods** buttons in the graph toolbar.

#### 3. Navigate the graph – Y-Axis

Press the **SHIFT key ↑**, left-click and drag the mouse over a Y-axis (Value axis) to move the individual Y-axis up or down.

To restore a Y-axis to its original position, right-click the axis and select **Reset Offset**.

#### 4. View graph line values

In the **Water Supply Total Extractions** graph, click the **Show (Hide) Values** button to load the **Value tool**. Drag the **time box** left and right to display the values of the graph signals in the graph lines.

**Left-click** in the graph to move the Value tool to the mouse cursor.

Click the **Hide Values** button to remove the Value tool.

#### 5. View graph line points

Click the **Show (Hide) Points** button to display all measuring points in the graph lines.

Click the **Hide Points** button to remove the graph points again.
6. **Zoom an area**

Click the **Zoom In** button and select an area on the X-axis (time) by click-and-drag the cursor in the graph with the mouse.

The selected area is zoomed in and a zoom window is displayed in the upper right hand corner of the graph. You can zoom an area again if you like to increase the detail of the graph.

Use the mouse to drag the X-axis back several minutes or you can drag the zoom area in the zoom window to display another graph area.

You can also use the **Zoom Area** button and click-and-drag the cursor to zoom in on a specific area covering both X-axis (time) and Y-axis (value).

7. **Zoom out from an area**

Click the **Zoom out** button to zoom the graph area one zoom step out.

If you have zoomed multiple times, you can restore the original graph zoom level by right-clicking the graph and selecting **Reset Zoom**.

8. **Hide and Highlight graph signal(s)**

In the graph, right-click the **Sum of total extractions** signal and select **Hide all others**.

Note the Y-axis for the hidden signals is removed and hidden signals are dimmed.
Right-click the VSSTP signal and select **Show** to display the VSSTP signal

Right-click the **Sum of total extractions** signal and select **Highlight** to emphasize the signal and Y-axis.

If you want to **restore** the graph again:
- Right-click a signal and select **Show all** to display all signals.
- Right-click a signal and select **Remove all highlights**

9. You can also use the graph tool bar to **Print** and **E-mail** the graph as well as **Save** it to the local pc and **Export to CSV** (comma separated data in Excel file).

10. Close the **Water Supply Total Extractions** graph.

**Task 2:**
**Create and save a dynamic Operator Graph**

You can also create an operator graph on-the-fly, defining the requirements and display options as you need them.

In this exercise, you create a new operator graph based on an embedded graph, save it for future use on your local pc and then retrieve the graph for display on the screen. First, you must change diagram to the Diary Production diagram.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Project Examples</strong> diagram, click the <strong>IGSS Training</strong> button to open the <strong>Training Diagram Overview</strong>. Open the <strong>Dairy Production</strong> diagram.</td>
</tr>
</tbody>
</table>
2. In the Dairy Production diagram, right-click the $q_1$ – Flow water in object and select **Show Graph** to open a new graph and add the $q_1$ object.

![Diagram showing the right-click action on the $q_1$ object to open a new graph.]

3. In the diagram, right-click the $q_2$ – Flow outlet object and select **Add to Graph > Operator** graph to add the $q_2$ object to the new operator graph.

![Diagram showing the right-click action on the $q_2$ object to add it to the operator graph.]

4. Click on the Diary Production diagram to display the diagram again.
5. In the diagram, right-click the \texttt{q3 – Flow water} object and select \texttt{Add to Graph > Operator} graph to add the \texttt{q3} object to the new operator graph. The graph now includes signals from 3 objects.

6. In the graph toolbar, click the \texttt{Save} button to open the \texttt{Save As} form.
   
   In the \texttt{File name} field, enter: “Flows Graph” (Do not include the quotation marks in the name) and press the \texttt{Save} button to save the graph in .usr format.

7. Close the operator graph.

8. In the \texttt{Supervise} menu, click \texttt{Graph > Open Operator Graph} and open the \texttt{Flows Graph.usr} graph to display the graph on the screen again. Close the graph.

9. You can work with an embedded graph (zoom in, show values, e-mail etc.) the same way as the window graph in task 1. To access the options:
   
   \begin{itemize}
   \item Right-click on the embedded graph, or
   \item Use the graph tool bar if displayed
   \end{itemize}

   NB! To display the tool bar, right-click the graph, select \texttt{Properties > Options} tab and the \texttt{Display Graph Toolbar} box.

\begin{table}[h]
\centering
\begin{tabular}{|c|c|}
\hline
\textbf{Step} & \textbf{Action} \\
\hline
1. & In the \texttt{Supervise} menu, click \texttt{Graph > Create Operator Graph} to open the \texttt{New Graph Properties Form}. In exercise 7 you will learn how to define the graph properties in this form. \\
\hline
\end{tabular}
\end{table}

\textbf{Task 3:}

\textbf{Create Operator Graph from start}

You can also create a new operator graph in \texttt{Supervise}, where you define the graph period, signals and chart properties (same as for pre-defined graphs).

\textbf{NB!} An operator can change graph properties (period, options etc.) by right-clicking any type of graph. However, changes can only be saved if the graph is saved as an operator graph.
The Object Historian

Purpose

Learn how to view and save data for selected objects in the project.

Task 1: Select the objects for which data is required

You select can view four different event types in the Object Historian:

- Log data
- Alarm data
- BCL data
- User login/logout

Step | Action
--- | ---
1. | In IGSS Master > Home tab, click the Start button to start the demo. Click the Supervise button to open the demo diagram. In the menu of the Supervise process diagram, click Area > Training Click the Refuse Disposal diagram

2. | In the Refuse disposal diagram, select the p1 object with the mouse, press the Shift tab ↑ and select the p2 object too.

3. | In the menu, click Edit > Object Historian to open the Object Historian form.

![Image of demo diagram]

The two objects (p1 and p2) are displayed in the Object Historian form, but we need to include the p3 object as well.
4. Click the **Browse** button to open the **Object Browser** form.

Find the **p3** object, drag it to the **Object Historian** form, close **Object Browser**.

**Tip** - See Exercise 1: Working as an Operator in IGSS Online in Supervise mode for instructions on how to locate objects in the **Object Browser** form.

The **Object Historian** form should now contain three objects: **p1**, **p2** and **p3**.

5. Click the **Query Data** button to gather data for the three objects: **p1**, **p2** and **p3**.

The **Object Historian’s** main pane will be populated with the data observations for the objects: **p1**, **p2** and **p3**.

6. In the **Time interval** group, set the start and end dates and the start and end time parameters to gather data from:
   - One hour ago
   - 5 minutes ago

Click **Query Data** to gather the data with the defined start and end dates/times.
7. The **Object Historian** form displays log data, but you can change the type of data displayed in the **Event Types** groups.

Click the **Export as CSV** button to save the data presented in the Object Historian main pane as a comma-separated file.

You can use the comma-separated file as input in other programs such as MS-Excel to create advanced tables and graphs or import the values in another database program to continue working with the values.

Try to change the parameters in the **Time interval** and **Event types** groups to see the effects on the data gathered.
Exercise 2: Creating a new IGSS Project

**Purpose**
Learn how to create a new project from scratch in IGSS Master. We will set up all the stations in the system, the global parameters and configure the PLC drivers.

**Duration**
30 - 40 minutes.

**Task 1:**
Create a new project & set up an IGSS server

You will now be creating your own project and populating it with objects, diagrams and elements of your own.

The new project will be defined as an IGSS Server and operator station project and you will set up the server and define the project configuration. Later, you will create the process diagram as well as objects and symbols for the project.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click Home tab &gt; Stop button to stop the current project</td>
</tr>
<tr>
<td>2.</td>
<td>Click the Project tab to switch to design mode.</td>
</tr>
<tr>
<td>3.</td>
<td>In the Design and Setup menu click the Project Wizard button. In the welcome dialogue click Next to proceed.</td>
</tr>
<tr>
<td>4.</td>
<td>Select Create a new IGSS project and click Next.</td>
</tr>
<tr>
<td>5.</td>
<td>Assign the name “Exercise” to the project and save it in this location: C:\IGSS\Training Project. Click Next to proceed.</td>
</tr>
<tr>
<td>6.</td>
<td>In the next dialogue, select the Server station type and click the Next button.</td>
</tr>
<tr>
<td>7.</td>
<td>Give the station the name IGSS_Server (see form below)</td>
</tr>
<tr>
<td>8.</td>
<td>Click the New Driver button and select driver “7TS7TCP” in the list. The driver has the ID 72. Note, that you can sort the driver names and numbers by clicking the column headers. Click the OK button.</td>
</tr>
</tbody>
</table>
9. Click the **New Interface** button. The text *IPNetwork* appears. This driver uses an IP connection to reach the PLC.

10. Click the **New Node** button to create node number 0. This is the unique identifier of the PLC.

11. Click the **Next** button twice to proceed as we want to also create an operator station.

12. Select **Add an operator station** and click the **Next** button.

13. Assign the name **OP1** to the operator station.

   Notice that all other buttons are inaccessible. This is because we are defining an operator station without connections to PLCs.

   Click the **Next** button to proceed.

14. In the **What is the IP address (or host name) of the primary IGSS Server?** field, enter the IP address of your computer.

   For training purposes, you can enter a fictional IP address e.g. **10.168.21.118** since we will not be connecting operator stations to the server. You can also enter the name of the IGSS server the OP1 is to connect to – e.g. **IGSS_Server**.

   Click the **Next** button to proceed.

   **Tip:** How to find the IP address on your own computer:

   Click the **Windows Start button** and search for **Command Prompt**. A new icon is now added to your Windows Start menu. Click the **Command Prompt** icon, and type **IPCONFIG** in the black Windows Command Prompt window. The IP address of your computer will now be shown.

15. Click **Finish** to complete the wizard.

   The **System Configuration** form is opened (see the screenshot below).
Exercise 2: Creating a new IGSS Project

16. In the left pane, right-click IGSS_server and select This PC.

Task 2: Set up global parameters

Before you can continue, you must set up and define the global parameters for the project. You do this using the various tabs in the System Configuration form.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Click the Configuration tab. Verify in the display-only fields that you have loaded the correct project. This should be the project you created in the previous task.</td>
</tr>
<tr>
<td>2.</td>
<td>In the following fields on the Configuration tab, enter the values:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Scan intervals (msec)</th>
<th>Log changes (%)</th>
<th>Base intervals (min)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2000</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>5000</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>8000</td>
<td>5</td>
<td>10</td>
</tr>
<tr>
<td>12000</td>
<td>15</td>
<td>20</td>
</tr>
</tbody>
</table>

OBS! Do not enter data in the other fields on this tab.
3. Click the **Files** tab.  
   In the **Data size** group at the top, enter “72” in the **Log files** field to enable the system to save the data from the log files for 72 hours.

4. Click the **Access Control** tab.  
   In the **Access control** group, make sure the **Disable access control** check box is selected.

5. Click the **Alarm** tab.  
   In the **Alarm counter** Group, select the **Display alarm count icon** and the **Display system tray icon** check box and enable the **Count no. of alarms** option.

6. Click the **Supervise & Language** tab.  
   In the **Options** group, select the following check boxes:
   - Allow diagram move
   - Allow graph move and resize
   - Enable inhibit alarms menu
   - Show active server name in status bar

7. Click the **Startup** tab.  
   In the **Startup** group, select the **Auto** option.

8. Click the **Data Collection** tab  
   In the **Data Collection** group, select the **Run simulated** check box.  
   In the **Advanced** group:
   - Select the **Validate input values against range** check box.
   - Select the **Enable calculations at runtime** check box.

9. Click the **Reports** tab.  
   In the **Headings** group:  
   - In the 1. **Line** field, enter “Training Plant”  
   - In the 2. **Line** field, enter “Training Workshop”  
   - Click the **Browse** button to the right of the **Logo file** field and navigate to C:\ Program Data \ Schneider Electric \ IGSS32 \ V13.0 \ GssDemo \ Images \ Icons \ Icon_master.png, which is the graphic that will be shown when generating reports.  

   **Tip:** To find the Icon_Master.png file, remember to select All Files (*.*) in the drop-down list in the browser window. The default setting is Logo files (*.bmp, *.gif, *.jpg)
<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.</td>
<td>Go back to the <strong>System Configuration</strong> form, click the <strong>Save project</strong> button ( <img src="image.png" alt="Save" /> ) in the top menu to save your work.</td>
</tr>
<tr>
<td>11.</td>
<td>In the <strong>System Configuration</strong> form menu, click <strong>File &gt; Exit</strong> to exit the <strong>System Configuration</strong> form.</td>
</tr>
<tr>
<td>12.</td>
<td>Click the <strong>Yes</strong> button to save your system configuration settings.</td>
</tr>
<tr>
<td>13.</td>
<td>In the <strong>IGSS Master</strong> dialog, click the <strong>Yes</strong> button to install and deploy the changes to your project.</td>
</tr>
<tr>
<td>14.</td>
<td>In the <strong>Installation options</strong> form, select <strong>Do not generate report</strong> and click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>
Exercise 3: Create Areas and Diagrams in Definition

Purpose
- To learn how to create areas and diagrams (in Definition).
- To insert an existing graphic file as the static background picture for the diagram.

Duration
10 - 15 minutes.

Task 1: Create a new area
After having created a new project and saved the setup parameters, you have to create the area where the diagram is to be placed and thereafter import the process diagram for the project as the project you just created is completely empty.

You need to open the project in the Definition module and begin the actual construction of the process diagram.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, Click Design and Setup tab &gt; Definition button to open the Definition menu. This is where you will be doing most of the work when you create or edit a project’s process diagram.</td>
</tr>
<tr>
<td>2.</td>
<td>In the menu of the Definition menu, click Area &gt; Create to open the New Area Properties form.</td>
</tr>
</tbody>
</table>
| 3.   | In the New Area Properties form (see screen dump under step 4)  
- In the Name field, enter: “Workshop”  
- In the Description field, enter: “Training Workshop”  
- In the Default Node field, enter: “0”  
- Select the Name to Menu and Visible in Mobile check boxes  
- In the Default Driver field, select “7TS7TCP(IGSS_SERVER)” |
| 4.   | Click the OK button to create the new area.  
You can verify if the new area exists and is selected by clicking the Area menu.  
The Workshop area should be selected in the Area menu. |
Task 2: Create a diagram

After having created the area which is to contain the process diagram, you must create the diagram. You can create your own diagram, using external drawing programs and importing the diagram or create a diagram with a solid background color.

For the rest of the exercises, we will be using the diagram depicted below and you will be importing the diagram in your project in this exercise. Later you will be creating objects and symbols for the project, placing them in the diagram.

The Training.jpg image which is used as the diagram background is located on the training USB or the computers supplied by IGSS training.
### Step 1
In the menu in the **IGSS Definition** menu, click **Diagram > Create** to open the **New Diagram Properties** form. On the **Definition of New Diagram** tab:

- In the **Name** field, enter “Training”
- In the **Description** field, enter “Workshop Project”

### Step 2
Under **Windows Properties**, select the **Name** radio button plus **Title bar, System menu, minimize, Keep aspect ratio, Name to menu** and **Visible in Mobile** (to include the project in the **IGSS Mobile App.**)

### Step 3
In the **Background** group, select **Picture**, click the **Browse** button, find the image file **Training.jpg** and click the **Open** button:

- On the training computer on **C: \ IGSS \ Training Files** folder
- On the training USB in the folder **Training Project Images**

**Tip**: Copy all images to your project folder to avoid losing them when the USB stick is removed, and when working on the project on another pc.

### Step 4
In the **New Diagram Properties** form, click **OK** to import the background picture into the diagram. If needed, adjust the diagram size by right clicking on the image and changing **Height** and **Width** in the **Diagram Properties** form.

### Step 5
In the **IGSS Definition** menu, click **Format > Set Initial Display** to make this graphic the first one that appears at system startup.

In the **IGSS Definition** menu, click **File > Check and Deploy** to save the process diagram and to run a check of the diagram before installing it to the project.

**Tip**: You will be using **Check and Deploy** frequently and it is a good idea to remember the shortcut key (**CTRL+W**) for this function.
Exercise 4: Creating IGSS Objects on the Process Diagram

Purpose
Learn how to create new objects for the process diagram and how to use the copy/paste functions to replicate objects of identical nature.
In the next exercise, we’ll learn to work with templates, which is another method for replicating objects with similar characteristics.

The Task
We need to create the two flow gauges (analog objects q1 and q2) as well as a counter for the operational hours of the mixer motor (C1) and place them in the process diagram. We need to set up the alarm definitions and alarm texts for the gauges and the counter as well as set up the required connections and data collection parameters.
We also need to create a color-coded pump symbol that quickly displays to the user whether or not the pump is running.
Finally, as an optional task, we can create and define our own measurement units and assign the measurement designations to the relevant objects: The flow gauges and the counter (q1, q2 and C1)

Duration
30 - 45 minutes.

Task 1:
Create the first flow gauge.
We will create two analog objects and name them q1 and q2 which measure water flow.
### Exercise 4: Creating IGSS Objects on the Process Diagram

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
</table>
| 1.   | In the IGSS Master. Click Design and Setup tab > Definition button to open the Definition menu.  
In the menu of the Definition menu, click Area > Workshop.  
In the menu of the Definition menu, click Diagram > Training. |
| 2.   | In the process diagram, right-click the mouse at the position where the flow gauge q1 is to be placed (see above) and select New > Analog Elements to open the Object Browser form. |
| 3.   | In left pane of the Object Browser form, expand the Workshop folder and select the Analog folders. At the bottom of the Object Browser form:  
- in the Name field, enter “q1”  
- in the Description field, enter “Flow water in”  
- Select the Advanced check box to unfold the rest of the form.  
- Click the Create button to create the q1 analog object and to open the q1 object properties form. |

![Object Browser form](image)
4. Click the **Symbol Definition** tab. In the **Choose symbol** group’s **Symbol table** field, click **Analog Elements** and select the flow symbol flow symbol:

![Symbol Definition Tab](image)

**OBS!** Do not click OK at the bottom of the form yet before you have done the actions on the other tabs in the form. If you click OK and close the form, you can always open the form by right clicking on the object and selecting **Properties**.

5. Click the **Display** tab in the **Object Properties** form. In the **Show** group:
   - Under **Label**, select the **Name** check box
   - Under **State / Value**, select the **Enable** check box
   - In the **Availability** group select **Visible in Mobile**.

![Display Tab](image)
6. Click the **Atom Mapping** tab to enable the alarm atoms needed to define alarm limits for your object. In the **Atom** group: set check mark in **High Alarm**, **Actual Value** and **Low Limit**.

Verify that the **High Limit**, **Set point**, and **Low Alarm** check boxes are cleared.

![Atom Mapping screenshot](image)

7. Click the **Analog** tab

- In the **Max.** field, enter: “100”.
- In the **Min.** field, enter: “0”
- In the **Decimal Point** field, enter: “1”
- Select the **High Alarm** check box and enter “95.0” in the input field
- In the **Actual Value** field, enter: “62.0”
- Select the **Low Alarm** check box and enter “19.0” in the input field

![Analog tab screenshot](image)

**Note** to the Analog tab form above:

The **Units** field is left empty. The optional task at the end of this exercise explains how to set up measurement units and apply them to the objects in the diagram.

The value in the **Actual Value** field is the initial value of the q1 object.
8. Go back to the Atom Mapping tab and to set up the atom properties of the High Alarm, Low Alarm and Actual Value atoms.

Set up High Alarm properties:

1) Mark High Alarm next to the ticked-off check box
2) In the I/O Mode field select “Local” for the high alarm.
3) In the Alarm Details Group:
   a. Click the New button to open the Edit Alarm form.
   b. Verify the value in the Alarm no. field is “101”.
   c. In the Alarm text field, enter “High alarm on flow”
   d. In the Priority field, enter “10”
   e. In the Instructions field, enter “Reduce inlet!”
   f. Click the OK button
Exercise 4: Creating IGSS Objects on the Process Diagram

Set up Actual Value properties:

1) Mark Actual Value
2) In the I/O Mode field select “in” for the actual value.
3) In the PLC Node for object q1 Group:
   a. Verify the Driver: field contains the PLC driver we chose in System Configuration (7TS7TCP (IGSS_Server))
   b. Verify the Node: field value is “0”.
   c. In the Data Block Number field, enter: “6”
   d. In the Offset field, enter: “0”
   e. In the Bit Offset field, enter: “1”

Set up Low Limit properties:

1) Mark the Low Limit
2) In the I/O Mode field select “local” for the low limit.
3) In the Alarm Details Group:
   a. Click the New button to open the Edit Alarm form.
   b. Verify value in the Alarm no. field is “102”.
   c. In the Alarm text field, enter “Low limit reached”
   d. In the Priority field enter “5”
   e. In the Instructions field, enter “Open inlet!”
   f. Click the OK button
9. Click the **Data Management** tab.
   - In the **Scan interval** Group, select the **2000** option.
   - In the **Logging** Group, select the **All changes** option
   - In the **Base interval** Group, select the **10** option
   - In the **Data Reduction** Group, select the **Average** check box
   - In the **Transfer to History** Group, select **Reduced value**

10. Click the **OK** button to create the **q1** analog object

11. Adjust the placement of **q1** in the process diagram.

12. The **q1** object is created using a small font size by default.

   You can change the font size of the text for the **q1** object by selecting all the elements of the **q1** object, right-clicking and selecting **Font**.

   Select a font size which displays well in the diagram, for example a font size 12.
You have completed creating the first flow gauge, q1. Continue to create the next flow gauge, to be named q2.

You can create the q2 gauge by copying and adjusting the already existing q1 analog object.

### Task 2:
**Create the q2 flow gauge object.**

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition menu in the process diagram, right-click the q1 analog object and select Copy.</td>
</tr>
<tr>
<td>2.</td>
<td>Right-click the process diagram and select Paste &gt; As new object&lt;br&gt;The original q1 is replicated but with a new name. q1_1&lt;br&gt;(Why do you suppose this happens?)</td>
</tr>
<tr>
<td>3.</td>
<td>Drag the new object to its correct position on the right side of the process diagram (see the image above)</td>
</tr>
<tr>
<td>4.</td>
<td>Right-click the q1_1 object and select Properties&lt;br&gt;Select the Analog tab and in the Name field, enter “q2”&lt;br&gt;Select the Atom Mapping tab. In the Atom group select the Actual Value check box and mark the text. In PLC Address for the Actual Value atom group:&lt;br&gt;• In the Data Block number field, enter: “6”&lt;br&gt;• In the Offset field, enter: “1”&lt;br&gt;• In the Bit Offset field, enter: “1”&lt;br&gt;(Why do you have to change the values in these fields?)</td>
</tr>
<tr>
<td>5.</td>
<td>Click OK to save the changed name and settings of the new object q2.</td>
</tr>
</tbody>
</table>

This completes creating the two flow gauges q1 and q2.
Now we’ll create another type of IGSS object called a **Counter** object. This object, called **c1**, will be used to count the operational hours of a mixer motor, which we’ll create at a later time. For now, we’ll create the object and place it as shown on the diagram below.

**Task 3:**
Create a counter object

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>We will use a new graphical element to represent this object.</td>
</tr>
<tr>
<td></td>
<td>In the menu, click <strong>Objects &gt; Rectangular Field</strong> to open the <strong>Object browser</strong> form.</td>
</tr>
<tr>
<td></td>
<td>Expand the <strong>Workshop</strong> folder in the left pane and click on the <strong>Counter</strong> folder.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Name</strong> field, enter “c1”.</td>
</tr>
</tbody>
</table>
|      | In the **Description** field, enter “Operational hours for mixer”.
|      | Click **Create** to open the **c1 - Operational hours for mixer** form. |
| 3.   | In the **c1 - Operational hours for mixer** form, click the **Counter** tab |
|      | • In the **Current count** field, enter “100” as the default value of the counter. |
|      | • Select the **Limit** check box and enter “150” in the input field to the right of the **Limit** check box. |
|      | • In the **Preset value** field, enter “15” |
|      | • In the **Maximum value** field, enter “200” |

**Note** - The **Units** field is left empty. The optional task at the end of this exercise explains how to set up and apply measurement units to objects in the diagram.
Exercise 4: Creating IGSS Objects on the Process Diagram

4. In the c1 - Operational hours for mixer form, click the Data Management Definitions tab
   - In the Scan interval group, select the 5000 option
   - In the Logging group, select the >5 % option
   - In the Base interval group, select the 10 option
   - In the Data reduction group,
     o Select the Minimum and Maximum the check box
     o Clear all other check boxes in the group.
   - In the Transfer to History group, select the Reduced Value option

5. Click the Display tab. In the Show group under Label, select the Name check box. Under State/Value, select the Enable check box.

6. Select the Atom Mapping tab. In the Driver field in the PLC Node for object c1 group, ensure the 7TS7TCP driver is selected. The value in the Node field should be “0”

Set up the Command properties:

1) In the Atom Group, select the Command check box and mark the text
2) In the PLC address for Command atom group:
   a. In the Data Block Number field, enter “24”
   b. In the Offset field, enter “1”
   c. In the Bit Offset field, enter “0”
   d. In the External Type field, select “FP16S” from the dropdown menu.

![Image](object_properties.png)
Exercise 4: Creating IGSS Objects on the Process Diagram

Set up the **Count** properties:

1) In the **Atom** Group, select the **Count** check box and mark the text Count
2) In the **PLC address for Count atom** group:
   a. In the **Data Block Number** field, enter “23”
   b. In the **Offset** field, enter “0”
   c. In the **Bit Offset** field, enter “0”
   d. In the **External Type** field, select “FP16S” from the dropdown menu.

Set up the **Limit** properties:

1) In the **Atom** Group, select the **Limit** check box and mark the word Limit
2) In the **I/O mode** field, select “local”
3) In the **Alarm Details** group
   a. Click the **New** button to open the **Edit Alarm** form.
   b. Verify the value in the **Alarm no.** field is “103”.
   c. In the **Alarm text** field, enter “Counter limit exceeded”
   d. In the **Priority** field enter “10”
   e. In the **Instructions** field, enter “Use Auxiliary mixer”
   f. Click the **OK** button.

Set up the **Preset** properties:

1) In the **Atom** Group, select the **Preset** check box
2) In the **PLC address for Preset atom** group:
   a. In the **Data Block Number** field, enter “24”
   b. In the **Offset** field, enter “2”
   c. In the **Bit Offset** field, enter “0”
   d. In the **External Type** field, select “FP16S” from the dropdown menu.

7. Click the **OK** button to create the **c1** counter object. A grey rectangle appears.

8. In the process diagram, right-click the **c1** counter object and select **Properties**

9. In the **c1 - Operational hours for mixer** form, click the **Attributes of Rectangle** tab
   In the **Background Color** group, select the **Transparent** check box.

   In the **Frame and Border** group, select the **Enable** check box

   Click the **Settings** button to open the **Frame/Border Settings** form and:
   - Click the **Frame Color** button and select a **dark red** color.
   - In **Frame Thickness** field, select or enter “5”
   - Click the **OK** button to save the border and frame settings.
   - Click the **OK** button to save the rectangle settings for the **C1** counter object.

10. Place the **c1** counter object in the process diagram as depicted above.
Our next task is to place a simple on-off pump on the process diagram and represent it with a graphic from the Animated Symbol library.

**Task 4:** Attach a symbol, to the digital pump

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the menu, click <strong>View &gt; Drawing Toolbar</strong> to open the <strong>Drawing toolbar</strong>.</td>
</tr>
</tbody>
</table>
| 2.   | In the **Drawing toolbar**, activate (click) the **Animated symbol** button ( ), and then click somewhere in the process diagram.  
A graphic descriptor of a blower appears in the diagram. |
| 3.   | Double click the graphic to open the properties page for **Animated Symbol**.  
![Diagram of Animated Symbol properties page]  
| 4.   | In the **Categories** pane, scroll down, select the category **Pumps** and one of the pumps in the second line of the **Symbols in category** pane. |
Select the **Stretchable** check box and observe what happens to the graphic.

Clear the **Stretchable** check box again.

5. Click the **OK** button and the graphic comes onto the diagram.

6. Position the pump graphic as shown below.

7. We now need to create a digital object with no display.

   In the menu, click **Objects > New Unreferenced**... to open **Object Browser**.
8. In the left pane, expand the Workshop > Digital folder and select the (None) folder.

9. In the Create new object group
   - In the Name field, enter ”p4”
   - In the Description field, enter ”2-state”

10. Click Create to open the Object properties form for p4. Notice there is no Display tab

11. Click the Data Management tab and
   - Select the 5000 option in the Scan interval group
   - Select the None option in the Logging group
   - Select the 5 option in the Base interval group
   - Select the Change check box in the Data reduction group
12. Click the Atom Mapping tab and in the Atom group:
   - Select the Command check box then select “local” in the I/O mode field.
   - Select and mark State then select “local” in the I/O mode field.

13. Click the OK button.

14. On the diagram, right-click on the pump graphic and select Connect.

15. In the Object Browser find and select the pump p4 and click the Open/Select button.
   The pump graphic is now connected to the object properties we defined for p4 and the new Animated Symbol tab has been added to the properties tabs for the pump.

16. Click the Animated Symbol tab and in the upper left hand corner in the drop down box with the default setting In alarm, select the <0 setting. This is the OFF state for p4 and the pump.
   - In the Fill Color Mode field, select “Shaded”
   - In the Fill Color field, select a blue color

   Return to the drop down box and select the <1 setting, which is the ON state for q4 and the pump.
   - In the Fill Color Mode field, select “Solid”
   - In the Fill Color field, select a dark green color
   - Click Background Color to open the Colors form and select a yellow color.
17. Click the Display tab and
   - In the Label sub-group, select the Name check box
   - In the State / Value group
     - select the Enable check box
     - In the Atom field, select “Command”

18. Click OK to finish and save. The pump should now be blue, representing the OFF state.

Task 5: Using Calculation on p4
Our final task is to use the Calculation function to automatically control the pump, p4. Our aim is to ensure that p4 is stopped every time the flow through the gauge q1 is greater than a given speed.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
</table>
| 1.   | Right-click on the p4 graphic and select the Properties option  
      Click the Calculation tab. |
| 2.   | In the Atom group, select the Command check box  
      In the Execution trigger group, select the On object changes in expression option. |
3. **In the Command field, enter:** `IIF(\text{Value}('q1')>28, 0, 1)`
   
   This expression will set the command to 0, stopping the pump (p4) if the value of \textit{q1} exceeds 28 m$^3$/hr., otherwise the pump will continue to run (the command is set to 1). **NB!** Calculations are case sensitive, so write “Value”, NOT “value”.

4. **Click Test Expression...** to verify that the syntax is correct.
   
   The **Definition** dialog box should display the text:
   
   \textit{Expression is OK. Expression result IIF(Value('q1')>28, 0,1) = 0.000000}
   
   Click OK to close the **Definition** dialog.

5. It is a good idea to provide a short description of what the expression is supposed to perform.
   
   **In the Comment field,** enter "\textit{The pump runs until the flow on q1 is greater than 28, then the pump is automatically stopped.}"

6. **Click OK.**

7. **Right-click on the flow gauge q1 and select the Properties option.**
   
   Click the **Calculation** tab and select the **Actual value** box in the **Atom** group.
   
   - In the **Execution Trigger** group, select the **On fixed timer** option and enter “1000” in the **Timer value (in mSecs.)** field.
   - In the **Actual Value** field in the **Expression** group, enter \((\text{Value}('q1')+4) \mod 100\)
Exercise 4: Creating IGSS Objects on the Process Diagram

- Select the **Only execute expression if this condition is true** check box.
- In the field under the box, enter “\texttt{MSecsSinceLastExec()>3000}”
- In the **Comment** field, enter: “The gauge is incremented with 4 every 3 seconds until it reaches its maximum of 100. Then it falls to zero and is incremented by 4 again until it reaches 100”.

### 8. Click the **Test Expression**… button to verify correct syntax.

The **Definition** dialog box should display the text:

- **Condition syntax is OK.**
- **Condition result: FALSE (-0.000000)**
- **Expression is OK.**
- **Expression result**: \(\text{Value('q1')+4 \ MOD 100 = 66.000000}\)
- Click **OK** to close the dialog.

### 9. Click **OK** to save the calculation settings for the pump \(p4\).

### 10. In the Standard toolbar, click the **Save** button.

In the menu, click **File > Check and Deploy** – or **Ctrl + W** - to perform a check of the diagram and objects and to install the project.

If there are any errors in the project, an error dialog will appear, allowing you to correct any errors. The project will not be installed if there are any errors, but you can still save the project and troubleshoot the errors later.

### 11. Click **OK** to close the **Definition** dialog to close the **Definition** window

### 12. In the **IGSS Master**, click **Home** tab > **Start** button to start the project.

Click the **Home** tab > **Supervise** button to open the process diagram.

The pump is colored blue, indicating it has stopped.

Right-click (or left-click) the \(p4\) pump and select **1->** to start the pump. Notice the color change of the animated pump symbol to green.

Right-click the \(p4\) pump again and select **0->** to stop the pump. The color of the animated pump symbol changes back to blue.

**EXPLANATION:**

**Atom:** we choose the **Actual Value** atom to manipulate with our expression

**Execution trigger:** We choose to have the expression executed on the basis of time intervals, **On timer, Timer value (in mSecs)** in this case 3000 milliseconds
**Exercise 4: Creating IGSS Objects on the Process Diagram**

**Expression:** We want the 4 units to be added to the **Actual Value** of the flow gauge (Value('q1')+4), and when the maximum range of q1 is reached, which is 100, then we want to start anew with the **Actual Value** being set to zero, MOD 100.

**Only execute expression if this condition is true:** We don’t want the addition of 4 units to occur until at least 3000 milliseconds have elapsed since the last time 4 units were added, MsecsSinceLastExec()>3000

**RESULT:** the q1 flow gauge will register an increase in flow with increments of 4 until it reaches 100 at which time it will go back to zero and begin anew.

**OPTIONAL TASK:**

**Create a new Units set for use in defining objects**

Complete this optional task if you have time left after completing all the other tasks in this exercise.

We wish to create a set of abbreviations for measurement units, which we will then be able to choose for any object in our project. These will appear on the tab where the name of the object can be changed, for instance on the **Analog** tab for analog objects.

You must create the following measurement abbreviations:

- **m³/hr.** to indicate the flow per hour through a gauge.
- **Hrs.** to indicate the number of hours the mixer motor and the pump has been in operation.
- **m.** to indicate the water level in the water tank.

**Create measurement abbreviations**

1. Go to the **Definition** module.
2. In the menu, Click **Edit > Measurement Units...** to open the **Base Units** form.
3. Click the **New** button to open the **Edit Base Unit** form.
4. In the **Unit text** field, enter “m³/hr” which is the abbreviation of the first measurement unit you need. Click **OK**.
5. Click the **New** button again, enter “Hrs.” and click **OK**.
6. Click the **New** button again, enter “m” and click **OK**.
7. Click the **Close** button to leave the **Base Units** form.

**Tip:** If you make a mistake, delete the base unit entry or edit it in the **Base Units** form.
Update the objects in the diagram with the measurement abbreviations

After you have created the measurement abbreviations, you must go back to the objects in the Exercise project and add the appropriate unit in the Units field of the objects.

There are three objects you must adjust:
- Flow gauges q1 (Analog object), uses the m³/hr measure
- Flow gauge q2 (Analog object), uses the m³/hr measure
- The mixer motor counter C1 (Counter object), uses the hrs. measure.

You can access the objects unit field in three methods:
- Through the object in the process diagram
- Through the Object Browser form
- Through the Property table View form

The following instructions cover all three of the methods of accessing an object.

Update objects through the object in the Process Diagram

1. In the process diagram, right-click the q1 object and select Properties.

2. Click the Analog tab. In the Units field, select the “m³/hr” value from the drop-down list in the field.

3. Click the Display tab and select the Units box to display the units in the diagram.

   NB! This is first possible when the Enable box under State / Value is ticked off.

4. Click the OK button to close the form.
### Update objects through the Object Browser (Ctrl + E)

1. In the menu, click **File > Object Browser** to open the **Object Browser** form.

2. In the **Object Browser** form, expand the **Workshop/ Analog** folders in the left pane and select the **Analog** folder.

3. Select the q2 object in the list in the right pane and click the **Open / Select** button in the **Open by name** group.

4. The q2 object is displayed with an animated symbol in the process diagram.

5. In the process diagram, right-click the q2 object and select **Properties**.

6. Click the **Analog** tab. In the **Units** field, select the “m³/hr” value from the drop-down list in the field.

7. Click the **Display** tab and select the **Units** box to display the units in the diagram.

8. Click the **OK** button to close the form.

### Update objects through Property Table View

1. Right-click in an empty area in the process diagram and select **Property table view...** - or **Ctrl + H**

2. In the **Property table view** form, expand the **Training > Objects > Standard** folders in the left pane and select the **Counters** folder.

3. In the right-pane, in the **Unit** column double-click the empty cell for the **C1 @ Workshop** counter and select the **Hrs.** value in the drop-down list.

4. In the **Property table view** form, expand the **Training > Descriptors > Rectangular fields** folder in the left pane.

5. In the right pane of the **Property table view** form, find the **Rect. Field: C1@Workshop** row.

   Scroll right to find the **Show Units** column, double-click the cell and select **Yes** in the drop-down list to display the units in the diagram.

6. Click the **X** to close the **Property table view** form to return to the process diagram.
Exercise 5: Create Templates and Template Based Objects

Purpose

- Learn how to create templates and create objects with a template.
- Understand the benefits of using templates.

Duration

30 - 45 minutes.

Task 1: Create an analog template

We will create an analog template to be used later when we create level gauges.

Templates are created in and contained in Areas. If you want to make your templates globally available, create the template in the Global area.

TIP

When you name your template, use CAPITAL LETTERS so the template can be easily identified when determining object characteristics.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master. Click Design and Setup tab &gt; Definition button to open the Definition module. In the menu: Click Area &gt; Workshop. Click Diagram &gt; Training.</td>
</tr>
<tr>
<td>2.</td>
<td>Click Template &gt; Create to open the Create Template form.</td>
</tr>
</tbody>
</table>
| 3.   | In the Create Template form:  
  - In the Area field, select “Global”  
  - In the Type group, select the Analog option  
  - In the Name field, enter “LEVEL” |
| 4.   | In the LEVEL – level gauge form, click the Atom Mapping tab  
In the Atom Group:  
Select the High Alarm and the Actual Value check boxes. |
5. In the **Template Properties:LEVEL @ Global– level gauge** form, click the **Analog** tab
   - In the **Description** field, enter “Level gauge”
   - In the **Max.** field, enter: "10.00"
   - In the **Min.** field, enter: "0.00"
   - In the **Decimal point** field, enter: "2"
   - In the **Units** field, select "m." (see note)
   - Select the **High Alarm** check box and in the input field to the right of the **High Alarm** check box, enter: "9.00"
   - In the **Actual Value** field, enter: "5.00"

**Note**
If you have not defined the measurement abbreviations in the optional task for exercise 4, you can skip defining the **Units** field.

6. Click the **Atom Mapping** tab.

Set up **High Alarm** properties:
   1) In the **Atom** group, select the **High Alarm** check box
   2) In the **I/O Mode** field select “Local” for the high alarm.
   3) In the **Alarm Details** Group:
Exercise 5: Create Templates and Template Based Objects

<table>
<thead>
<tr>
<th>Exercise 5: Create Templates and Template Based Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>a. Click the <strong>New</strong> button to open the <strong>Edit Alarm Description</strong> form.</td>
</tr>
<tr>
<td>b. Verify the value in the <strong>Alarm no.</strong> field is “104”.</td>
</tr>
<tr>
<td>c. In the <strong>Alarm text</strong> field, enter “High alarm exceeded!”</td>
</tr>
<tr>
<td>d. In the <strong>Priority</strong> field, enter “10”</td>
</tr>
<tr>
<td>e. In the <strong>Instructions</strong> field, enter “Take corrective action!”</td>
</tr>
<tr>
<td>f. Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

Set up **Actual Value** properties:

1) In the **Atom** group, select the **Actual Value** check box and mark text
2) In the **I/O Mode** field select “in” for the actual value.
3) In the **PLC Node for object: LEVEL** Group:
   a. Verify the **Driver** field contains the PLC driver we chose in System Configuration (7TS7TCP (IGSS_Server))
   b. Verify the **Node** field value is “0”.
   c. In the **Data Block Number** field, enter: “21”
   d. In the **Offset** field, enter: “14”
   e. In the **Bit Offset** field, enter: “0”
   f. In the **External type** field, select “FP16S”
4) Make sure the **following atom check boxes** are cleared:
   - High Limit
   - Set Point
   - Low limit
   - Low Alarm
   - Alarm In
   - Alarm Out
   - High Scale
   - Low Scale
   - Free Value 1
   - Free Value 2
   - Free Value 3
   - Free Value 4
   - Free Value 5
   - Free Value 6
### Exercise 5: Create Templates and Template Based Objects

#### Task 2:
Create a digital template

After having created the analog object template, we will to create a digital object template which we will be using to create a number of pumps later on.

**TIPS**
When you create the digital object template, remember to create it in the **Global** area and name it with **CAPITAL LETTERS**.

When you define the Command/State configuration in step 7, use this table:

<table>
<thead>
<tr>
<th>When the state is active...</th>
<th>The following commands are accessible:</th>
<th>Color of pump symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>Slow</td>
<td>Red</td>
</tr>
<tr>
<td>Slow</td>
<td>Stop</td>
<td>Yellow</td>
</tr>
<tr>
<td></td>
<td>Medium*</td>
<td></td>
</tr>
<tr>
<td>Medium</td>
<td>Slow</td>
<td>Green</td>
</tr>
<tr>
<td></td>
<td>Fast</td>
<td></td>
</tr>
<tr>
<td>Fast</td>
<td>Medium</td>
<td>Blue</td>
</tr>
</tbody>
</table>

**Explanation**

The table illustrates the following relationship:

- When the pump is **Off**, the only available command is **Slow**.
- When the state of the pump is **Slow**, the available commands are **Stop** and **Medium**, where Medium is the default value.
- When the state of the pump is **Medium**, the available commands are **Slow** and **Fast**.
- When the state of the pump is **Fast**, the only available command is **Medium**.

The pump symbol’s color reflect the pump’s state. So if a pump is off the symbol for that pump will red, and if the pump is running fast, the symbol will be blue.

**About use of color:** The **ISA 101 Standard** for Human-Machine Interface (HMI) design recommends the use of white color for running state and dark grey for stopped only. If additional state change info is needed, text can be added. In this exercise we just use different colors to show the possibilities of the IGSS system.

---

<table>
<thead>
<tr>
<th>7.</th>
<th>Click the <strong>Data Management</strong> tab</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• In the <strong>Scan interval</strong> group, select the <strong>5000</strong> option.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Logging</strong> group, select the <strong>&gt; 2%</strong> option.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Base interval</strong> group, select the <strong>10</strong> option.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Data Reduction</strong> group, select the following check boxes:</td>
</tr>
<tr>
<td></td>
<td>• Average</td>
</tr>
<tr>
<td></td>
<td>• Minimum</td>
</tr>
<tr>
<td></td>
<td>• Maximum</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Transfer to History</strong> group, select the <strong>Reduced value</strong> option.</td>
</tr>
<tr>
<td>8.</td>
<td>Click <strong>OK</strong> to create the LEVEL analog object template.</td>
</tr>
</tbody>
</table>
Exercise 5: Create Templates and Template Based Objects

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> menu, click <strong>Template &gt; Create</strong> to open the <strong>Create Template</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the **Create Template** form:  
- In the **Area** field, select “Global”  
- In the **Type** group, select the **Digital** option  
- In the **Name** field, enter “PUMP”  
Click **OK** to open the **PUMP @ Global – 4-state pump** form. |
| 3.   | In the form, click the **Bit Map I/O** tab.  
In the **Description** field, enter “4-state pump”  
In the **To PC State** bit map, in the far right byte:  
- click once below the bit 1 to enable it as a state bit  
In the **From PC Command** bit map, in the far right byte:  
- click once below the bit 1 to enable it as a command bit  
A dash "-" will be displayed in the byte when you click correctly.  
**Note:** Do not click the lower row (the 1) in the byte.  
See the picture below |
| 4.   | Click the **Alarm In/Ack Bit** tab. In the **To PC** bit map, in the far right byte:  
- Click once below bit 0 to activate it as an alarm indication bit to PC (a plus sign "+" appears).  
- Click once below bit 1 to activate it as an alarm indication bit to PC (a plus sign "+" appears).  
- Click twice below bit 7 as alarm acknowledgement bit to PC (an asterisk "+*" appears). |
In the **From PC** bit map, in the far right byte:

- Click once below bit 7 to enable it as alarm acknowledgement bit from the PC (an asterisk "**" appears).

In the **Single Bits** group, select the **Alarms** check box

See the picture below.

---

5. **Click the States and Commands** tab.

In the **State** group:

- Select the `<0` state, in the input field, enter “Off” and click the **Add State** button. **Tip:** Use **Tabulator** and Enter to go to these fields.
- Select the `<1` state, in the input field, enter “Slow” and click the **Add State** button.
- Select the `<2` state, in the input field, enter “Medium” and click the **Add State** button.
- Select the `<3` state, in the input field, enter “Fast” and click the **Add State** button.
### Exercise 5: Create Templates and Template Based Objects

<table>
<thead>
<tr>
<th>In the <strong>Command</strong> group:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Select the <code>&lt;0</code> command, in the input field, enter “Stop” and click the <strong>Add Command</strong> button.</td>
</tr>
<tr>
<td>• Select the <code>&lt;1</code> command, in the input field, enter “Slow” and click the <strong>Add Command</strong> button.</td>
</tr>
<tr>
<td>• Select the <code>&lt;2</code> command, in the input field, enter “Medium” and click the <strong>Add Command</strong> button.</td>
</tr>
<tr>
<td>• Select the <code>&lt;3</code> command, in the input field, enter “Fast” and click the <strong>Add Command</strong> button.</td>
</tr>
</tbody>
</table>

**Note**

The **Add State** and **Add Command** buttons are only accessible if a value has been entered in the input field in the **State** and/or **Command** groups.

### 6. Click the **Data Management** tab.

- In the **Scan interval** group, select the **5000** option.
- In the **Logging** group, select the **All changes** option.
- In the **Base interval** group, select the **10** option.
- In the **Data Reduction**, group, select the **Change** check box.
- In the **Transfer to History** group, select the **Actual Total** Value.

### 7. Click the **Command/State Config** tab. In the **States** group:

- Select the **Off** state and in the **Commands** group, select **Slow**
- Select **Slow** and in the **Commands** group, select **Stop** and **Medium**
- Select **Medium** and in the **Commands** group, select **Slow** and **Fast**
- Select **Fast** and in the **Commands** group, select the **Medium** check box.

See hint at the beginning of this exercise for overview of states and commands.

### 8. Click the **Atom Mapping** tab.

Set up the **Command** properties:

1) In the **Atom** Group, select the **Command** check box
   a. In the **I/O Mode** field, select “out”
   b. In the **Driver** field, select “7TS7TCP (IGSS_Server)”
   c. In the **Node** field, select “0”

2) In the **PLC Node for Command atom** group:
   a. In the **Data Block Number** field, enter “22”
   b. In the **Offset** field, enter “10”
   c. In the **Bit Offset** field, enter “0”
   d. In the **External Type** field, select “FP16S” from the dropdown menu.
Exercise 5: Create Templates and Template Based Objects

Set up the State properties:

1) In the Atom Group, select the State check box and mark the text
   a. In the I/O Mode field, select “in”
   b. In the Driver field, select “7TS7TCP (IGSS_Server)”
   c. In the Node field, select “0”
2) In the PLC Node for State atom group:
   a. In the Data Block number field, enter “23”
   b. In the Offset field, enter “10”
   c. In the Bit Offset field, enter “0”
   d. In the External Type field, select “FP16S” from the dropdown menu.

Set up the Alarm-In properties:

1) In the Atom Group, select the Alarm-In check box
2) In the I/O Mode field, select “in”
3) In the Alarm Details group
   a. In the Digital Alarms field, select “<+ 1.”
   b. Click the New button to open the Edit Alarm form.
   c. Verify the value in the Alarm no. field is “105”.
   d. In the Alarm text field, enter “Pump defective”
   e. In the Priority field enter “100”
   f. In the Instructions field, enter “Change pump”
   g. Click the OK button.
   h. In the Digital Alarms field, select “<+ 2.”
   i. In the alarm text input field above the Digital Alarms field, select “105: Pump defective”.
4) In the PLC address for Alarm In group:
   a. In the Data Block Number field, enter “24”
   b. In the Offset field, enter “10”
   c. In the Bit Offset field, enter “0”
   d. In the External Type field, select “FP16S” from the dropdown menu.

Set up the Alarm-Out properties:

1) In the Atom Group, select the Alarm-Out check box
2) In the I/O Mode field, select “out”
3) In the PLC address for Alarm Out group:
   a. In the Data Block Number field, enter “25”
   b. In the Offset field, enter “10”
   c. In the Bit Offset field, enter “0”
   d. In the External Type field, select “FP16S” from the dropdown menu.

Note
The same alarm number and text is used for the two alarms for Alarm in. You can, as an optional exercise, create a new alarm number and text for the second alarm in.
Exercise 5: Create Templates and Template Based Objects

| 9. | Click the **Symbol Definition** tab. Use the ▶️ pump symbol to represent the pump in all its states. You must change the color-coding of the symbol though. In the **Digital state for symbol** group (right side):  
• Select “Off”  
• In the **Choose symbol** group in the **Symbol table** field, select **Blowers, Compr, Pumps** and select the **pump symbol** depicted above.  
• In the **Symbol properties** group, select a **red** color for the symbol. Under **Copy/paste symbol settings** click the **Copy from selected state** button and click the **Paste to all states** button to copy the symbol and symbol properties to all the states of the PUMPS template. In the **Digital state for symbol** group:  
• Select “Slow”  
• In the **Choose symbol** color field in the **Symbol properties** group, select a **yellow** color for the symbol. In the **Digital state for symbol** group:  
• Select “Medium”  
• In the **Symbol properties** group, select a **green** color for the symbol. In the **Digital state for symbol** group:  
• Select “Fast”  
• In the **Choose symbol** color field in the **Symbol properties** group, select a **blue** color for the symbol. In the **Template inheritance** group:  
• Select the **Store symbols in template** check box to make symbols and colors available to objects based on this template. | 10. | Click the **OK** button at the bottom of the **PUMP – 4-state pump** form to save the digital template. |

**Task 3:** Create a new object based on the template **LEVEL**

After having created the two templates, you need to augment the process diagram with some new symbols and pictures.

You will create and place a pipe symbol and an image to represent the water tank in the process diagram. Finally, you will use the **LEVEL** analog template to create a new object (L1).

The **L1** analog template will be used to monitor the level of the water in the water tank and will resemble a bar-meter.
Exercise 5: Create Templates and Template Based Objects

### Step 1

1. In the **Definition** module’s menu, click **View > Drawing toolbar** to display the **Drawing toolbar** in the **Definition** form.

   You can skip this step if the **Drawing toolbar** is already displayed.

### Step 2

2. Create and position the pipe in the process diagram.

   In the **Drawing Toolbar**, click the **Pipes** button (\[\]) and draw a pipe in the diagram.

   **Tip:** Press **Escape** or **Enter** or **double-click** to complete the pipe and to stop drawing vertices. If you have created more vertices (waypoints) than you need, you can delete them by right-clicking the vertex and selecting **Delete vertex**. The mouse pointer changes to a crosshair when it is near a selectable vertex.

   Place the pipe in the diagram and right-click and select **Properties** to open the **Descriptor Properties** form.

   In the **Geometry property** group:

   - Double-click the **Line Width** property and define a fitting width for the pipe, e.g. 28
   - Double-click the **Start Cap** property and define a start cap for the pipe. Select the fourth start cap type.
   - In the **Static Colors** property group:
     - Double-click the **Line Color** property and in the **Color** form, select a light gray line color.

   Click **OK** to exit the **Descriptor Properties** form and save the pipe settings.

   In the diagram, position the pipe so it covers the area it is supposed to.
3. **Create and position the water tank image.**

   - In the **Drawing Toolbar**, click the image icon and drag it into the process diagram. Click in the process diagram to place the image.
   - The **Open an image file** form is opened.
   - Navigate to `C:\ IGSS \ Training Files` and select the `TANK-36.emf` image. The image is also found in the `C:\ Program Data \ Schneider Electric \ IGSS32 \ V13.0 \ GSSDemo \ Images` folder as well as on the USB stick in the `Training Project Images` folder.
   - Click **Open** to import the image file into the process diagram.
   - Resize and position the water tank image according to the diagram.

4. **Create and position the L1 analog water level meter.**

   In the menu in the **Definition** module, click **Objects > Bar** to open the **Object Browser** form.

   In the left pane of the **Object Browser** form, expand the **Workshop / Analog** folder and click the **LEVEL** folder. In the **Create new object** group:

   - In the **Name** field, enter “L1”
   - In the **Description** field, enter “Water level in tank”

   Click the **Create** button to open the **L1 - Water level in tank** form.
5. Click the **Atom Mapping** tab.
   - In the **Atom** group
     - Select the **Actual Value** atom
   - In the **PLC address for Actual Value Atom** group
     - In the **Offset** field, enter “10”

6. In the **L1 - Water level in tank** form, click the **Bar Properties** tab
   - Clear the **Show** scale check box in the **Scale** group
   - Clear the **Show Values** check box in the **Scale values** group
   
   In the **Actual Value** group
   - Select the **Bar** check box
   - Clear the **Arrow** check box
   - Clear the **Line** check box

   In the **Alarms** group
   - Clear the **Lines** check box
   - Clear the **Arrows** check box
   - Clear the **Areas** check box

7. Click the **OK** button in the **L1 - Water level in tank** form to create the **L1** object.

8. Position and resize the **L1** bar display object to fit within the tank opening.

**Task 4:**
After having created the analog object, symbols and images, you can now create three new pumps (**p1**, **p2**, **p3**) based on the **PUMP** template and place the pumps according to the diagram displayed below.

![Diagram showing placement of pumps p1, p2, and p3](image)
### Exercise 5: Create Templates and Template Based Objects

#### IGSS Configuration Workshop - Exercises

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> menu, click <strong>Objects &gt; Blowers, Compr and Pumps</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the left pane of the **Object Browser** form, expand the **Workshop > Digital** folder and click the **PUMP** template folder.  

In the **Create new object** group:
- In the **Name** field, enter “p1”  
- In the **Description** field, enter “Pump”  

Click the **Create** button to open the **p1 - Pump** form. |
| 3.   | In the **p1 @ Workshop - Pump** form, click the **Atom Mapping** tab.  

Give the **p1** pump a unique PLC address by adding a new **Offset**:

Set up the Command properties:
1) In the **Atom Group**, select the **Command** check box  
2) In the **PLC address for Command atom** group’s **Offset** field, enter “11”  

Set up the State properties:
1) In the **Atom Group**, select the **State** check box and mark State  
2) In the **PLC address for State atom** group’s **Offset** field, enter “11”  

Set up the Alarm-In properties:
1) In the **Atom Group**, select the **Alarm-In** check box  
2) In the **PLC address for Alarm-In atom** group’s **Offset** field, enter “11”  

Set up the Alarm-Out properties:
1) In the **Atom Group**, select the **Alarm-Out** check box  
2) In the **PLC address for Alarm-Out atom** group’s **Offset** field, enter “11” |
Exercise 5: Create Templates and Template Based Objects

4. In the p1 - Pump form, click the Symbol Definition tab
   - In the Template inheritance group, select the Inherit symbols from template check box. The template’s symbols and colors will be replicated to the p1 object.
   - Click the Off, Slow, Medium and Fast states in the Digital state for symbol group to verify that the symbols and colors have been replicated correctly.

5. Click the OK button to create the p1 digital object
   Place the p1 object in the process diagram as shown in the image above.

6. Repeat steps 1 to 6 for the p2 and p3 digital objects.
   In step 3, set the value in the offset field as follows:
   - p2 Offset field value: 12
   - p3 Offset field value: 13

Task 5: Optional Task
Update the LEVEL Analog Template

The LEVEL Analog Template from task 1 above was created without setting the low alarm limits and defining a low alarm.

You must update the LEVEL Analog template to include a new low alarm.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition menu, click Template &gt; Edit to open the Edit Template form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the Edit Template form, select the Global area and the Analog option, and find the LEVEL template in the Name field’s drop-down box. Click OK to open the LEVEL @ Global – Level gauge properties form.</td>
</tr>
<tr>
<td>3.</td>
<td>On the LEVEL @ Global – Level gauge properties form, click the Atom Mapping tab, select the Low Alarm box and make sure the text is highlighted.</td>
</tr>
</tbody>
</table>
4. Click the Analog tab and set the **Low Alarm** value to 2.00.

5. Click the Atom Mapping tab

    In the Atom group
    - Mark the **Low Alarm** check box and highlight the text
    
    In the I/O Mode field select “Local” for the low alarm.
    
    In the Alarm Details Group:
    1) Click the New button to open the Edit Alarm Description form.
    2) Verify the value in the Alarm no. field is “106”.
    3) In the Alarm text field, enter “Low alarm exceeded!”
    4) In the Priority field, enter “10”
    5) In the Instructions field, enter “Take corrective action!”
    
    Click **OK** to close to save the adjustment to the LEVEL template.

6. In the process diagram, right-click the L1 object and select **Properties**.

    Verify the low alarm has been activated and set up on the Analog and Atom Mapping tabs, and close the Properties form.
Exercise 6: Create and Show Events

Purpose

In this exercise you will create different types of events. The event types can be divided into three main categories:

- System events
- Periodical events
- User defined events

The events will be shown in the Event List which is shown just below the Alarm List in the Active Alarms list, which can be accessed from the IGSS Master, Supervise and Definition modules, when the system is running.

The list is fully user defined, so you decide yourself which events to show.

The events can be defined both from the Definition and Supervise forms.

Task 1: Create a system event

We will define an event to occur every time the project is started or stopped.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition form, click Edit &gt; Event List... to open the Events form</td>
</tr>
<tr>
<td>2.</td>
<td>In the Events form, click the Add button to open the Edit Event form</td>
</tr>
<tr>
<td>3.</td>
<td>In the Edit Event Form’s Event group:</td>
</tr>
<tr>
<td></td>
<td>- In the Name field, enter “Start/Stop of project”</td>
</tr>
<tr>
<td></td>
<td>- In the Type field, select “System Start/Stop”</td>
</tr>
<tr>
<td></td>
<td>- Select the To History check box to save the event in the event log.</td>
</tr>
</tbody>
</table>
Exercise 6: Create and Show Events

4. Click the OK button to add the event type to the Events form.
5. In the Events form, click the Close button.

**Task 2: Create a periodical event**

In this task we will create a monthly event which tells the operator to email a report to the municipal authorities.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Edit &gt; Event List...</strong> to open the Events form</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Events</strong> form, click the <strong>Add</strong> button to open the <strong>Edit Event</strong> form</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Edit Event</strong> Form&lt;br&gt;<strong>In the Event group</strong>&lt;br&gt; a) In the <strong>Name</strong> field, enter “E-mail report to municipal authorities”&lt;br&gt; b) In the <strong>Type</strong> field, select “Periodical”&lt;br&gt; c) Select the <strong>Alarm on event</strong> check box to display the event in the Alarm List.&lt;br&gt; d) Select the <strong>To History</strong> check box&lt;br&gt; e) In the <strong>Period</strong> field, select “1” and “Months”&lt;br&gt; f) In the <strong>First event at</strong> field, enter yesterday’s date.</td>
</tr>
<tr>
<td>4.</td>
<td>Click the OK button to add the event type to the Events form.</td>
</tr>
<tr>
<td>5.</td>
<td>In the Events form, click the Close button.</td>
</tr>
</tbody>
</table>
Task 3: Create a user defined event

One of the two pumps must be running all the time to supply the tank with water. Therefore, we want an event (and an alarm) if both pumps are stopped at the same time.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Edit &gt; Event List</strong> to open the <strong>Events</strong> form</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Events</strong> form, click the <strong>Add</strong> button to open the <strong>Edit Event</strong> form</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Edit Event</strong> Form</td>
</tr>
<tr>
<td></td>
<td>In the <strong>Event</strong> group</td>
</tr>
<tr>
<td>a)</td>
<td>In the <strong>Name</strong> field, enter “p1 and p2 stopped”</td>
</tr>
<tr>
<td>b)</td>
<td>In the <strong>Type</strong> field, select “User defined”</td>
</tr>
<tr>
<td>c)</td>
<td>Select the <strong>Alarm on event</strong> check box</td>
</tr>
<tr>
<td>d)</td>
<td>Select the <strong>To History</strong> check box</td>
</tr>
<tr>
<td></td>
<td>In the <strong>Criteria</strong> group, create the first criteria</td>
</tr>
<tr>
<td>e)</td>
<td>Click the <strong>Add Criteria</strong> button to create a new criteria</td>
</tr>
<tr>
<td>f)</td>
<td>Click the <strong>Object Browser</strong> button to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>g)</td>
<td>Find the <strong>p1</strong> pump (click the <strong>Training &gt; Digital</strong> folder)</td>
</tr>
<tr>
<td>h)</td>
<td>Drag the <strong>p1</strong> object from the <strong>Object Browser</strong> form precisely (cursor = +) into the <strong>Object/template</strong> field in the <strong>Edit Event</strong> form and <strong>Close</strong>.</td>
</tr>
<tr>
<td>i)</td>
<td>In the left-most <strong>Atom</strong> column, select “State”</td>
</tr>
<tr>
<td>j)</td>
<td>In the <strong>Relation</strong> column, select “=(Value)”</td>
</tr>
<tr>
<td>k)</td>
<td>In the <strong>Object</strong> column, enter “0” (which means the pump has stopped)</td>
</tr>
</tbody>
</table>
the Edit Event form, click the Add Criteria button to create the second criteria.

- In the Type field, select “AND”
- Click the Object Browser button to open the Object Browser form.
- Find the p2 pump in the Training > Digital folder
- Drag the p2 object from the Object Browser form into the Object/template field of the newly created criteria in the Edit Event form.
- In the left-most Atom column, select “State”
- In the Relation column, select “=(Value)”
- In the Object column, enter “0” (which means the pump has stopped)

4. Click the OK button to add the event type to the Events form.

5. In the Events form, click the Close button.
Task 4: Test the events

We will now start the project and stop both pumps to trigger the user defined event.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>File &gt; Check and Deploy</strong>.</td>
</tr>
</tbody>
</table>
| 2.   | (If the project is not started)  
In the **IGSS Master**, click **Home tab > Start** to start the project. |
| 3.   | In the **IGSS Master**, click **Home tab > Supervise** to open the **Supervise** form. |
| 4.   | Open the **Active Alarms** form (the **Alarm List**):  
- In **IGSS Master**, click the Alarm clock icon, or  
- In **Supervise** click the Alarm icon. |
| 5.   | In the lower left pane in **the Active Alarms form**, click the **Event log** folder  
Notice that the “Start/stop of configuration” event is displayed in the **Event List**. |
| 6.   | Stop both the pumps **p1** and **p2**.  
- In the **Supervise** form, find the **p1** object in the diagram right-click and select the “Stop” option.  
- Find the **p2** object, right-click and select the “Stop” option. |
| 7.   | Open the **Active Alarms** form (the **Alarm List**).  
Verify that the “p1 and p2 stopped” event is displayed in the **Event List** and the alarm number 90 (alarm generated by event) appears in the **Alarm List** pane above. |
Exercise 7: Create a Graph time plot

**Purpose**
Create a graph in a window, add signals for object atoms and define the graph properties. Set a user-defined graph period.

The graph is then made available for operators through the Graph menu.

**Duration**
15 - 20 min.

**Task 1: Create a time plot**
Create a time plot graph, displaying the process values from the two analog object flow gauges, q1 (shown in 3 different states) and q2.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Graph &gt; Create</strong> to open the <strong>New Graph Properties</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the **New Graph Properties** form > **Window** tab:  
  - In the **Name** field, enter “FlowmeterGraphs”  
  - In the **Description** field, enter “Flowmeters q1 and q2”  
  In the **Graph Menu** group:  
  - Select the **Name to Menu** check box  
  - Select the **Description to Menu** check box |
| 3.   | Select the **Period** tab:  
  In the **Select display period** field, select **This year**. Under **Start month**, select 3 (March) and a **Start hour** between 0 and 23.  
  **Tip**: You can also select relative periods (e.g. 3 months back) or a custom period, where you define to/from date and time below. |
| 4.   | Select the **Signals** tab to add signals from objects to the graph:  
  1. Click the **Add** button to open the **Object Browser** form.  
  2. In the **Object Browser** form > **Wild card text criteria** field, enter “q1” and select the q1 object in the right pane of the **Object Browser** form |
Exercise 7: Create a Graph time plot

3. Click the **Open/Select** button to add the object as a signal to the graph
4. Click the **Add** button again to open the **Object Browser** form again
5. In the **Object Browser** form > **Wild card text criteria** field, enter “q1” and select the q1 object in the right pane of the **Object Browser** form
6. Click the **Open/Select** button to add the object as a signal to the graph
7. Click the **Add** button again to open the **Object Browser** form again
8. In the **Object Browser** form > **Wild card text criteria** field, enter “q1” and select the q1 object in the right pane of the **Object Browser** form.
9. Click the **Open/Select** button to add the object as a signal to the graph
10. Click the **Add** button again to open the **Object Browser** form again
11. In the **Object Browser** form > **Wild card text criteria** field, enter “q2” and select the q2 object in the right pane of the **Object Browser** form.
12. Click the **Open/Select** button to add the object as a signal to the graph

There should be three q1 and one q2 object signals in the graph now.

5. In the **New Graph Properties** form > **Signals** tab:
   In the **Object** pane:
   1. Select first the q1@Workshop signal
   2. In the **Basic** sub-tab > **Atom** field, select **High Alarm**.
   3. In the **Appearance** group, select a **bright red Line Color** for the signal line
   4. In the **Legend text for signal** field, enter “High Alarm”

   ![New Graph Properties](image)

   **Tip:** If you add the graph to a diagram in an IGSS version 11 or older, you may want to choose **Classic colors** to match the color scheme.

   1. Select the second or middle q1@Workshop signal (Actual value)
### Exercise 7: Create a Graph time plot

2. In the **Basic** sub-tab, select a **blue** Line Color for the signal line.
3. In the **Legend text for signal** field, enter “Flowmeter q1”.

In the **Object** pane:
- Select the third the **q1@Workshop** signal.
- In the **Basic** sub-tab > **Atom** field, select **Low Limit**.
- Select a **bright red** Line Color for the signal line.
- In the **Legend text for signal** field, enter “Lower Limit”.

In the **Object** pane:
- Select the **q2@Workshop** signal.
- In the **Basic** sub-tab, select a **green** Line Color for the signal line.
- In the **Legend text for signal** field, enter “Flowmeter q2”.
- Click the **Move up** button to move the **q2 Actual Value** signal on top of the **q1 Low Limit** signal.

The sort order in the **Object** pane should now be:
- **q1 High Alarm**
- **q1 Actual Value**
- **q2 Actual Value**
- **q1 Low Limit**

6. In the Signals tab’s **Advanced** tab select the **Show Y-axis** box, and under **Axis limits** select **Automatic with zero included**.

**Tip:** It is also possible to select **Fixed limits** and define min. + max. Y-axis limits for each signal. Atoms higher or lower will not be displayed in the graph.

7. In the **New Graph Properties** form > **Chart** tab:

   In the **Chart Title** field, enter: “Flowmeter graph for q1 and q2”.

   Select **Show legend** and where to place the legend.

   In the **For each signal** group:
   - Clear the **Show object/atom information** check box.
   - Select the **Show text defined for each signal** check box.

8. In the **New Graph Properties** form > **Options** tab:

   Clear the **Use automatic colors** check box.

   In the **Background color** field, click **More** and enter the following RGB values:
   - **Red**: 255
   - **Green**: 232
• Blue: 194

In the Grid color field, click More and enter the following RGB values:
• R: 255
• G: 232
• B: 194

(The color is also in the Recent Colors list)

The Text Color and Axis color fields are not changed.

9. In the Options tab’s User interface group, select Display graph toolbar and Display graph status, to help the operator navigate the graph in Supervise.

10. In the Options tab’s Options group, select Show data points and Show values.

   Tip: If this results in too much information in the graph, you can also decide to deselect these and/or Hide value and/or Time labels and/or Scale.

11. You can save the defined graph properties as default, which are already set next time you open the form to create a new graph. To do so, select the Set as Default check box at the bottom of any tab in the Graph Properties form.
12. Click **OK** to save the graph properties, close the form and view the graph.

13. **Check and Deploy** (or check...) your changes and test the graph in the Supervise module.

**Task 2: Adjust the graph's appearance**

**Optional**

In this exercise we will change the background and grid colors plus the appearance of some of the object signals to see the difference.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> module’s top menu, click the <strong>Graph</strong> menu and select <strong>FlowmeterGraphs</strong> to open the graph.</td>
</tr>
<tr>
<td>2.</td>
<td>Right-click in the graph, open the <strong>Properties</strong> form and select the <strong>Options</strong> tab. Change the <strong>Background color</strong> to light grey, and <strong>Grid color</strong> to dark grey. Close the Properties form.</td>
</tr>
</tbody>
</table>
3. At the top of the graph, right-click on the legend for the blue q1 Flow water in – Actual value signal. Select the Highlighted and the Transparent boxes, and a dotted Pattern.

4. In the left pane, select the last q1@Workshop signal for the Lower limit. Change Line color to orange to make it different from the red High alarm signal.

5. In the left pane, select the last q2@Workshop signal (green). Select the Highlighted check box. Click OK to close the Graph Properties form and see how your changes have impacted the appearance of the graph.

6. Click the X in the top right corner to close the graph.
Exercise 7: Create a Graph time plot

**Task 3: Create a button**

Create a button in the diagram to open the time plot graph you created in the previous exercise.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.</td>
<td>In the <strong>Definition</strong> module, click the <strong>Button</strong> icon in the <strong>Drawing</strong> toolbar and click in the diagram where the button is to be placed.</td>
</tr>
</tbody>
</table>
| 8.   | **Create the button text (caption) and hover style**  
1. Right-click the button and select **Properties** to open the **Button Properties** form  
2. In the left pane of the **Properties** form, select **Miscellaneous**  
3. In the right pane, double-click the **Value** cell of the **Text to be displayed** field. Enter “Flowmeter Graph” in the **Text to be displayed** form and OK.  
4. In the left pane, select **Style**. In the right pane, double-click **Hover style** to select how you want the button’s appearance to change on mouse-over to indicate that it is clickable.  
5. Click the **OK** button to close the **Text to be displayed** form  
6. Click the **OK** button in the **Button Properties** form to save your changes and close the form |
| 9.   | Adjust the button size by dragging the corners of the button control with your mouse.  
You can also adjust the button control size by using the **Width (W)** and **Height (H)** fields in the **Position** toolbar.  
If the **Position** toolbar is not displayed, click **View > Position and Size toolbar**.  
Finally, you can also adjust the position and size of any descriptor or control by using the **Property Table View** form. |
Exercise 7: Create a Graph time plot

10. Connect the button to the graph
   - Right-click the Flowmeter Graph button and select Connect to open the Object Browser form.
   - In the left pane of the Object Browser form, click Workshop > Graph to display all Graph objects.
   - In the right pane, select the FlowmeterGraphs Graph object
   - Click the Open/Select button to open the Object Properties form.
   - In the Display tab > Label group, clear the Name check box
   - Click OK to save your changes and close the Object Properties form.

11. Check and Deploy your changes and test the graph in the Supervise module.

Optional

Task 4: Create a graph symbol

Instead of a button you can use a Graph symbol as reference for a graph

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Right-click on the place, you want the graph symbol, and select New &gt; Graphs to open the Object Browser. Alternatively, in the Objects menu click Graphs.</td>
</tr>
<tr>
<td>2.</td>
<td>In the Object Browser window’s left pane, click the + of the relevant project, and in its Graph folder select your newly created “FlowmeterGraphs” graph. The graph symbol and name is now inserted into the diagram.</td>
</tr>
</tbody>
</table>

Task 5: Create an Embedded Graph

You can also make the graph an integrated part of the diagram e.g. next to or as part of a descriptor or an object. Create an embedded graph that displays the process values L1 analog water level meter at the bottom part of the water tank.
### Exercise 7: Create a Graph time plot

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Create a new Embedded Graph inside <strong>the L1 water tank</strong>:&lt;br&gt; a) Place your cursor inside the tank and right-click. Select <strong>New &gt; Standard Descriptors &gt; Embedded Graph</strong>. Alternatively, in the top menu, select <strong>Objects &gt; Standard Descriptors &gt; Embedded Graph</strong>.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>New Embedded Graph Properties form</strong> (see step 3), in the <strong>Period</strong> tab select <strong>Custom duration</strong> and set the <strong>Duration</strong> to 15 minutes.</td>
</tr>
<tr>
<td>3.</td>
<td>a) In the <strong>Signals</strong> tab, click the <strong>Add</strong> button in the bottom left corner.  &lt;br&gt; b) In the <strong>Object browser</strong>, select the +Workshop folder and the L1 analog object. Click <strong>Open / Select</strong>.  &lt;br&gt; c) In the Signals tab’s <strong>Basic</strong> sub-tab: Select <strong>Actual Value</strong> under <strong>Atom</strong>; under <strong>Data source</strong> select <strong>Auto</strong>.  &lt;br&gt; d) Select a <strong>red line color</strong> for the signal.</td>
</tr>
<tr>
<td>4.</td>
<td>In the <strong>Chart</strong> tab, ensure that the boxes for the <strong>Show legend</strong> and <strong>For each signal</strong> are NOT selected. The embedded graph in the tank has no space to show it.</td>
</tr>
<tr>
<td>5.</td>
<td>Click the <strong>Options</strong> tab, deselect <strong>Automatic colors</strong> and select light grey as background color and grid color.  &lt;br&gt; Disable <strong>graph toolbar</strong> and <strong>status bar</strong> (no space). During supervision the operator can right-click the graph and use the graph menu to zoom, change period etc.  &lt;br&gt; Make sure that in the <strong>Options</strong> group all boxes are deselected as the graph has no space to also show data points, values, value labels/scale or time labels/scale.</td>
</tr>
</tbody>
</table>
| 6.   | In the **Visibility** tab, define under which conditions the graph is to be shown (or
not) inside the tank:

Select **Only show descriptor when visibility object**, click **Browse** and select the **Workshop** area and the L1 object and **Open / Select**.

Select the **Is in alarm** radio button. This means that the embedded graph will only be shown inside the tank when the L1 object is in alarm. The rest of the time it is “invisible”.

7. Click **OK** to save the embedded graph.

Click and drag the graph to place it nicely inside the L1 tank.

You can at any time edit the graph – just right-click the graph and select **Properties**.

8. In the **Definition** top menu, click **Format > Check and Deploy** ... to install the project with the updated diagram and the embedded graph.

9. Go to **IGSS Home**, start the **Training project**. Open the **Supervise** module and the **Workshop** diagram to see if the graph is shown inside the tank.

If not, it is because the L1 object is not in alarm. Right-click the L1 object and reduce the High Alarm and Low Alarm until the embedded graph appears.
Exercise 8: Create a Report Format and Generate a Periodical Report

Purpose
- Learn how to create report formats for printed reports.
- Learn how to generate reports.

Duration
20 - 30 minutes.

Task 1: Create a new report format and report headings
We will create a new report format for our printed reports and name the headings we want in the report. The report format will be called Packaging and the report format will cover all IGSS objects related to the packaging process and be used for generating a daily report.

The report will have three headings: Flow, Level and Pump and contain data from the following process components (objects):

- q1: Analog object - Flow meter 1
- q2: Analog object - Flow meter 2
- L1: Analog object - Water tank
- p1: Digital Object - Pump 1
- p2: Digital Object - Pump 2
- p3: Digital Object - Pump 3

Step | Action
---|---
1. | In the Definition Form, click Edit > Report Formats... to open the form.
2. | In the Report format click the Create button to open the Report Format Properties form.
3. | In the Report Format Properties form
   - in the Format name field, enter “Packaging”
   - Select the Set as default check box.
   - In the Report type group, select the Periodical report option.
   - Click the OK button to create the report format.
4. Create the 3 report headings you are going to use in the Report Formats form:

Create the Flow report heading

1) In the left pane, select the Packaging report format.
2) In the Report Heading group, click the Create button to open the Report Heading Properties form.
3) In the Heading Text field, enter “Flow”
4) Click the OK button to return to the Report Formats form.

Create the Level report heading in the same way. Mark the Packaging folder first.

Create the Pumps report heading in the same way.

5. You now have to include some of the objects under the created report headings.

Add q1 and q2 analog objects to the Flow report heading

1) In the left pane of the Report Formats form, click the Flow report heading.
2) In the Chosen Objects group, click the Browse button to open the Object Browser form.
3) In the Object Browser form, find and select the q1 analog object
4) Drag the q1 analog object into the right pane of the Report Formats form.
5) In the Object Browser form, find and select the q2 analog object
6) Drag the q2 analog object into the right pane of the Report Formats form.
Add 3 different L1 analog objects to the Level report heading:

1) In the left pane of the Report Formats form, click the Level report heading.
2) In the Chosen Objects group, click the Browse button to open the Object Browser form.
3) In the Object Browser form in the List Filter settings, select the Show reductions check box.
4) In the Object Browser form, find and select the L1 analog objects for Average, Minimum and Maximum data reduction.
5) Drag the L1 analog objects into the right pane of the Report Formats form.

Add the p1, p2 and p3 digital objects to the Pumps report heading

1) In the left pane of the Report Formats form, click the Pumps report heading.
2) In the Chosen Objects group, click Browse to open the Object Browser form.
3) In the Object Browser form, find and select all p1, p2 and p3 digital objects. Hint: Use “p*” in the Wild card text Criteria field.
4) In the Object Browser form, select the p1, p2 and p3 digital objects and drag them into the right pane of the Report Formats form.
5) In the Object Browser form, click the Close button to close the Object Browser form and return to the Report Formats form.

Note. Since you are defining a periodical report, only objects with assigned data reductions can be used. This is why the Show reductions check box was selected above. You can include one or more data reductions for L1 (Average, Minimum and/or Maximum).

6. In the Report Formats form, click the OK button to close the form.
7. In the Definition toolbar click the Save button to save your report format. Or, click File > Check and Deploy to save your report format.

Task 2: Generate a periodical report

You can now create a daily report based on the format we just created. To do this, you must exit the Definition form and use the IGSS Master to create the report.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Go to the IGSS Master module. If the project is not started, you must start the project as the report will not be accessible if the project is stopped. To start the project: In the IGSS Master, Click Home tab &gt; Start button.</td>
</tr>
</tbody>
</table>

**Note**
You can also select the Start Basic Service Only option in the drop-down in the Start button. Reports and Dashboards can be executed even if the project is only running with basic services.

| 2.   | In the IGSS Master module’s left navigation pane under the Reports heading, double-click the Packaging report to start the Generate Standard Report form. |

| 3.   | a) On the Generate tab, in the Report Date field, select today as the start date.  
  b) In the Output group, select the preview check box.  
  c) Click the Generate button to display a print preview of the report.  
  d) In the Generate Standard Report form, click the Close button to close the form. |
Exercise 9: Use Standard Descriptors and Drawing toolbar

Purpose

- Learn how to use standard descriptors including customized symbols.
- Learn how to connect standard descriptors to IGSS objects.

Duration

20 - 30 minutes.

Task 1: Connect an analog object to a polygon

A new level gauge (L2) is to be created and the L2 level gauge is to be based on the LEVEL template and connected a polygon. A polygon is one of the standard descriptors which you will create in the exercise.

The polygon will be set up reflect the current value of the water level in the tank.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Objects &gt; Standard Descriptors &gt; Polygon</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the left pane of the <strong>Object Browser</strong> form, expand the <strong>Workshop &gt; Analog</strong> folder and select the <strong>LEVEL</strong> template folder.</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Object Browser</strong> form in the <strong>Create New Object</strong> group in the <strong>Name</strong> field, enter “L2”</td>
</tr>
</tbody>
</table>
4. Click the **Create** button.

5. In the **L2** form, click the **Atom Mapping** tab
   
   In the **Atom** group, select the **Actual Value** check box.
   
   In the **PLC Address for Actual Value** atom group
   
   In the **Bit Offset** field, enter “2”.

6. Click **OK** to display the polygon descriptor in the process diagram as a triangle.
Exercise 9: Use Standard Descriptors and Drawing toolbar

<table>
<thead>
<tr>
<th>Exercise</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.</td>
<td>In the <strong>Definition</strong> menu, click <strong>Format &gt; Snap &gt; Smart</strong> to facilitate the positioning of graphics on the diagram.</td>
</tr>
<tr>
<td>8.</td>
<td>Drag the polygon triangle into the cutout for <strong>L2</strong>. Click the triangle, and hover the mouse over one of the vertices (the white ◼️ in the triangle corners). When the mouse cursor changes to display a cross-hairs + icon, <strong>double-click on one of the ◼️ vertexes to add a new vertex</strong>. You can also right-click the vertex and select <strong>Add Vertex</strong>. Add another handle to create five handles altogether. Move the five handles so that they fill out the entire cutout. In the <strong>Definition</strong> form, click <strong>Format menu &gt; Snap to Grid</strong> to remove the grid from the diagram display. <strong>Tip:</strong> To make a curved polygon, right-click on the polygon, select <strong>Properties &gt; Geometry</strong> and double-click on <strong>Draw As Curve</strong>. On the polygon, place the marker over a □, click and drag the polygon into the desired shape.</td>
</tr>
<tr>
<td>9.</td>
<td><strong>Tip:</strong> If you have several overlapping objects/descriptors, you can change an object’s position and send it forward (Ctrl + F) or backward (Ctrl + B), and to the front (+) or back (-) of the stack, alternatively use the <strong>Format</strong> menu. <strong>Exercise:</strong> Create min. 3 overlapping descriptors and change their position.</td>
</tr>
<tr>
<td>10.</td>
<td>Right-click on the <strong>L2</strong> polygon to open the <strong>L2</strong> object <strong>Properties</strong> form, and click the <strong>Attributes of Polygon</strong> tab. Edit background color 1) In the left pane, expand the <strong>Bindings to Object State</strong> folder and select <strong>Background Color</strong>. 2) In the right pane, double-click the Bind <strong>Background color</strong> field in the <strong>Value</strong> column to toggle to a “Yes” value. 3) Double-click the <strong>Above Alarm</strong> field in the <strong>Value</strong> column and select an orange color. 4) Double-click the <strong>Not in Alarm</strong> field in the <strong>Value</strong> column and select the white color.</td>
</tr>
</tbody>
</table>
Exercise 9: Use Standard Descriptors and Drawing toolbar

Edit object alarm bindings

1) In the left pane on the Attributes of Polygon tab, expand the click Bindings to object Alarms.
   a. In the right pane, double-click the Flash Background On Color field in the Value column and select an orange color.
   b. In the right pane, double-click the Flash Background Off Color field in the Value column and select an white color.
   c. Double-click the Flashing Background field in the Value column and toggle to the “Yes” option.

![Diagram of properties and values]

Edit Miscellaneous properties

1) In the left pane on the Attributes of Polygon tab, click Miscellaneous.
   a. In the right pane, double-click the ActiveFill Color field in the Value column and select a blue color to represent the tank filling up.

![Diagram of properties and values]

2) In the right pane, you can double-click Transparency, and move the slider to set transparency level for the polygon.

11. Click the OK button to save the changes and close the L2 form.
**Task 2:** Add a .gif image to the process diagram

You will add a new graphic (Prop-1.gif) from your machine to the Training process diagram, placing it in the motor block depicted below. The Prop-1.gif image is unconnected but you will be connecting the image later.

![Training Diagram with Prop-1.gif](image)

Position Prop_1.gif here

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1.</strong></td>
<td>The best way to create unconnected descriptors in the diagrams is by using the Drawing toolbar. In the Definition form, click View &gt; Drawing Toolbar to display the Drawing Toolbar. Skip this step if the Drawing Toolbar is already displayed.</td>
</tr>
<tr>
<td><strong>2.</strong></td>
<td>In the Drawing Toolbar, click the Image button <img src="image" alt="Image" /> and click in the Training diagram to place the image in the diagram. The Open an Image file form is displayed.</td>
</tr>
<tr>
<td><strong>3.</strong></td>
<td>In the Open an Image file form, navigate to C:\IGSS\Training Files folder and find the Prop-1.gif file</td>
</tr>
<tr>
<td><strong>4.</strong></td>
<td>Click the Open button to add the Prop-1.gif image to the Training Diagram.</td>
</tr>
<tr>
<td><strong>5.</strong></td>
<td>Place the Prop-1.gif image as indicated shown in the figure above.</td>
</tr>
</tbody>
</table>
You will create a motor object called M1 and represent the process component on the process diagram with a gif file instead of using a standard symbol.

The motor object is to be created based a new template called MOTOR, which we first have to create.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Template &gt; Create</strong> to open the <strong>Create Template</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the **Create Template** form:  
1) In the **Area** field, select “Global”  
2) In the **Type** group, select the **Digital** option.  
3) In the **Name** field, enter “MOTOR”  
Click the **OK** button to open the **MOTOR – Motor Digital Object Template** form. |
| 3.   | In the **MOTOR – Motor Digital Object Template** form, click the **Bit Map I/O** tab  
In the **Description** field, enter “Motor Digital Object Template”  
In the **To PC State** bit map, in the far right byte:  
   1. click once below the bit 0 to enable it as a state bit  
In the **From PC Command** bit map, in the far right byte:  
   1. click once below the bit “0” to enable it as a command bit  
A dash "-" will be displayed in the byte when you click correctly. |

**Note**
Do not click the lower row (the 1) in the byte.
4. Click the **Alarm In/Ack Bit** tab.

   In the **To PC** bit map, in the far right byte:
   - Click once below bit 0 to activate it as an alarm indication bit to PC (a plus sign "+" appears).
   - Click twice below bit 1 to activate it as an alarm acknowledgement bit (an asterisk "*" appears).

   In the **From PC** bit map, in the far right byte:
   - Click once below bit 0 to enable it as alarm acknowledgement bit from the PC (an asterisk "*" appears).

![Image of Motor Digital Object Template](Image)

5. Click the **States and Commands** tab.

   In the **State** group:
   - Select the `<0` state, in the input field, enter “Off” and click the **Add State** button.
   - Select the `<1` state, in the input field, enter “On” and click the **Add State** button.

   In the **Command** group:
   - Select the `0->` command, in the input field, enter “Stop” and click the **Add Command** button.
   - Select the `1->` command, in the input field, enter “Start” and click the **Add Command** button.

**Note:** The **Add State** and **Add Command** buttons are only accessible if a value has been entered in the input field in the **State** and/or **Command** groups.
6. Click the **Command/State Config** tab.
   In the **States** group, select the **On** state and in the **Commands** group, select the **Stop** check box.

7. Click the **Data Management** tab
   - In the **Scan interval** group, select the **5000** option.
   - In the **Logging** group, select the **All changes** option.
   - In the **Base interval** group, select the **10** option.
   - In the **Data reduction** group, select the **Change** option.
   - In the **Transfer to History** group, select the **Actual Total Value** option.

8. Click the **Atom Mapping** tab
   Set up the **Command** properties:
   1) In the **Atom** Group, select the **Command** check box
   2) In the **I/O Mode** field, select “out”
   3) In the **PLC address for object MOTOR** group:
      a. In the **Driver** field, select “7TS7TCP (IGSS_Server)”
      b. In the **Node** field, select “0”
      c. In the **Data Block number** field, enter “25”
      d. In the **Offset** field, enter “10”
      e. In the **Bit Offset** field, enter “0”
      f. In the **External Type** field, select “FP16S” from the dropdown menu.
Set up the **State** properties:

1) In the **Atom** Group, select the **State** check box and mark **State**
2) In the **I/O Mode** field, select “in”
3) In the **PLC address for State atom** group:
   a. In the **Data Block number** field, enter “26”
   b. In the **Offset** field, enter “10”
   c. In the **Bit Offset** field, enter “0”
   d. In the **External Type** field, select “FP16S” from the dropdown menu.

Set up the **Alarm-In** properties:

1) In the **Atom** Group, select the **Alarm-In** check box
2) In the **I/O Mode** field, select “in”
3) In the **Alarm Details** group
   a. In the **Digital Alarms** field, select “<= 1.”
   b. Click the **New** button to open the **Edit Alarm** form.
   c. Verify the value in the **Alarm no.** field is “106”.
   d. In the **Alarm text** field, enter “Motor defective”
   e. In the **Priority** field enter “6”
   f. In the **Instructions** field, enter “Call maintenance team”
   g. Click the **OK** button.
4) In the **PLC address for Alarm-In atom** group:
   a. In the **Data Block number** field, enter “27”
   b. In the **Offset** field, enter “10”
   c. In the **Bit Offset** field, enter “0”
   d. In the **External Type** field, select “FP16S” from the dropdown menu.

Set up the **Alarm-Out** properties:

1) In the **Atom** Group, select the **Alarm-Out** check box
2) In the **I/O Mode** field, select “out”
3) In the **PLC address for Alarm-Out atom** group:
   a. In the **Data Block number** field, enter “28”
   b. In the **Offset** field, enter “10”
   c. In the **Bit Offset** field, enter “0”

In the **External Type** field, select “FP16S” from the dropdown menu.

9. Click the **OK** button in the **MOTOR – Motor Digital Object Template** form to create the **MOTOR** digital template.
**Exercise 9: Use Standard Descriptors and Drawing toolbar**

**Task 4: Create the motor object and connect to a gif file**

After you have created the **MOTOR** digital object template, you can create the motor object called **M1** based on the **MOTOR** template.

As you already have a symbol you want to connect the **M1** digital object to (the **Prop-1.gif** image you created above), you don’t need to use a standard symbol from the IGSS standard symbol library to represent the motor.

Create the **M1** digital object **without** symbol representation.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Create the <strong>M1</strong> object by first selecting from the <strong>Objects</strong> menu the entry called <strong>New Unreferenced</strong>, which is found vertically down in the menu structure. In the <strong>Definition</strong> module, click <strong>Objects &gt; New Unreferenced</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Object Browser</strong> form, in the left pane, expand the <strong>Workshop &gt; Digital</strong> folder and select the <strong>MOTOR</strong> template.</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Create New object</strong> group, in the <strong>Name</strong> field, enter “<strong>M1</strong>” In the <strong>Description</strong> field, enter “Motor”</td>
</tr>
<tr>
<td>4.</td>
<td>Click the <strong>Create</strong> button to open the <strong>M1 – Motor</strong> form.</td>
</tr>
</tbody>
</table>
| 5.   | In the **M1 – Motor** form, click the **Atom Mapping** tab In the **Atom** group, select the **Command** check box.  
• In the **PLC Addresses** group, in the **Bit Offset** field, enter “10”. |
| 6.   | Click the **OK** button to create the **M1** digital object. |

**Note**

There is no graphical representation on the process diagram for the **M1** digital object yet.

If you open the **Object Browser** form (In the **Definition** form, click **File > Object Browser**) you can see that the **M1** digital object is present in the left pane of the **Object Browser** form under **Workshop / Digital / Motor**.

The **M1** digital object is not listed in the **Property Table Viewer** form, found by right-clicking the process diagram and selecting **Property Table View** form.

In the left pane of the **Property Table View** form, expand the **Objects / Standard / Digitals** folder. The **M1** digital object is not listed.

The **M1** object can be found by opening the **Area Property Table Viewer** found in **Area > Property Table View**. In the left pane of the **Area Property Table Viewer**, expand the **Objects > Standard > Digitals** folder to find the **M1** object.
Exercise 9: Use Standard Descriptors and Drawing toolbar

Task 5: Connect the gif graphic to the M1 object.

After you have created the M1 digital object based on the MOTOR digital object template, you can connect the Prop_1.gif to the M1 digital object and give it a graphical representation on the process diagram. The prop animated image is set up to play non-stop when the M1 digital object is turned on i.e. has the state On.

NB! The ISA 101 Standard recommends to NOT use moving objects in general, and to only use animated objects to highlight abnormal situations.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the process diagram, right-click on the motor image (Prop-1.gif) and select the Connect option to open the Object Browser form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the right pane, find and select the object M1 digital object.</td>
</tr>
</tbody>
</table>
| 3.   | In the Open by name group:  
  - select the Go to diagram check box  
  - select the Show properties check box  
  Click the Open / Select button to open the M1 – Motor form. |
| 4.   | In the M1 – Motor form, click the Attributes of GIF tab. |
| 5.   | In the left pane, expand the Properties > Bindings to Object State folder. Select the Play folder |
| 6.   | In the right pane double-click the Bind Play and On fields’ value column to toggle the field values to “Yes”. |
| 7.   | In the left pane, select the Miscellaneous folder. In the right pane’s Play Non Stop field, double-click the value column to toggle the field value to “Yes”. |
| 8.   | In the M1 – Motor form, click the OK button to save the M1 digital object settings and exit. The M1 digital object is now displayed in the process diagram.  
  Note: Right-click to open the Property Table View. Select the folder Descriptors > Video (or Objects > Standard > Digitals) and find the M1 digital object in the right pane. |
| 9.   | Test the M1 motor and the L2 polygon descriptors. Click File > Check and Deploy.  
  In the IGSS Master > Home tab, click the Start button to start the Training project and click the Supervise button to open the Supervise module.  
  Verify that the propeller for the M1 motor is running and the polygon descriptor for the L2 object looks correct. |
Optional Exercise

You can connect the pipe to the L1 water tank to better indicate when the L1 object is in alarm. The pipe is only to change color when the L1 object is in either high alarm or low alarm.

The object name, description and present value are not to be displayed.

You can also enable alarm blinking on the pipe when the L1 object is in alarm.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the diagram, right-click the pipe and select <strong>Connect</strong>. In the <strong>Object Browser</strong> form, locate the L1 object and click the <strong>Open/Select</strong> button to open the <strong>Object Properties: L1 @ Workshop</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | Edit the pipe properties to not display any values or names from the L1 object. In the **Object Properties: L1 @ Workshop** form > **Display** tab: 
  - In the **Label** sub-group, clear the following check boxes
    - Name check box
    - Description check box
  - In the **State / Value** group, clear the **Enable** check box |
| 3.   | Click the **Attributes of Polyline** tab. In the **Bindings to Object State** > **Line Color** property group: 
  - Double-click the **Bind Line Color** property to toggle the value to “Yes” 
  - Double-click the **Above Alarm** property and select a red color. 
  - Double-click the **Not in Alarm** property and select a light gray color. 
  - Double-click the **Below Alarm** property and select an orange color. Click the **OK** button to save the properties and close the form. |
| 4.   | Check and Deploy the project and test the pipe colors when the L1 object is in alarm. |

Tip: To make a curved line, right-click on the line, select **Properties > Geometry** and double-click on **Draw As Curve**. On the line, place the marker over a □, click and drag the line into the desired shape.
5. (Optional) You can also adjust the pipe properties to blink when the L1 object is in alarm.

In the Object Properties: L1 @ Workshop form > Attributes of Polyline tab:

In the Bindings to Object Alarms property group:

- Double-click the Flash Line property to toggle the value to “Yes”
- Double-click the Flash Line On Color property and select a red color.
- Double-click the Flash Line Off Color property and select a yellow color.

Click OK to save the properties and close the form.

6. Check and Deploy the project and test that the pipe blinks when the L1 object is in alarm.

Tip

The I/O mode field in the Atom Mapping tab on the Object Properties: L1 @ Workshop form must be set to “Local” to ensure the L1 Actual Value atom can be edited.

This will allow you to change the actual value when the Supervise module is running.

Optional Exercise

Task 7: Import a customized symbol.

In addition to the built-in categories of common descriptors for machinery, components, etc. in the Object Properties form’s symbol library, you can import any kind of pre-defined, custom made vector based symbol in .wmf format.

.wmf is a Windows Metafile image format, intended to be portable between applications, and may contain both vector graphics and bitmap components. It acts in a similar manner to .svg files.
### Step 1

A simple graphic symbol called **Blue_box_wmf_format** is located on your pc in the image folder on the workshop USB.

### Step 2

Import the pre-defined customized symbol into your IGSS diagram:

- **a)** If the Drawing Toolbar is not already available, select it in the View menu.
- **b)** In the Drawing Toolbar, click the **Animated Symbol** icon and drag it into the diagram, click and a machine drawing appears.
- **c)** Right-click on the machine symbol and select **Properties**.
- **d)** In the **Object Properties** form, select the **Custom Category** and click the **Import custom** button.

![Image of IGSS custom symbol selection](image)

- **e)** In the **Select a graphs to import** form, chose your .wmf file and **Open**.
- **f)** Select your custom made symbol in the **Custom Category** and click **OK**.

### Step 3

Connect your new symbol to the **p1** object:

- **a)** In the diagram, right-click your new symbol, select **Properties > Connect**.
- **b)** In the **Object Browser**, mark the **+ Workshop > Digital** folder, and select **p1 Pump water**, click **Open / Select** and **OK**.

![Image of connecting symbol to object](image)
4. In the Descriptor Properties form set-up your symbol to change appearance (color, blink etc.) according to the state of the p1 object (e.g. on, off, alarm):

- Right-click your new symbol and select Properties > Custom Category
- Mark your symbol. In drop-down box at the top right side of the Animated symbols tab, select the As a state radio button.
- In drop-down box at the top left side, select In Alarm.
  In the right side of the form under Fill color select Shaded and Red. Under Blink color, select Invisible. You symbol will now blink and change between red and invisible, when the object is in alarm.
- In drop-down box at the top left side, select ON and decide colors and animation pattern for how you want the object to look when turned ON.
- Change to OFF and define colors and animation for the object in OFF state.
Exercise 10: Create and deploy Faceplates

Create a new Area and Diagram

Contents

This lesson will create a faceplate master diagram from scratch, emulating the Refuse Disposal diagram in the Demo project and creating three identical refuse disposal plants based on a new faceplate master.

Access to the refuse disposal plant diagrams will be managed by a new Main diagram.

A new project and a new area for the faceplate master diagram must be created and afterwards two new diagrams are to be created – a Main diagram which will contain buttons for the Instance diagrams and the Faceplate master itself.

Duration

10 – 15 minutes.

Create a new IGSS Project

Purpose

The new IGSS project will be used in subsequent lessons as the foundation for the faceplate exercises.

Task 1: Create a new project

The new project will be called FaceplateConfig and will contain a new area and the main diagram, the Faceplate master diagram as well as all the faceplate diagrams.

The main diagram will contain buttons to the faceplates diagrams while the Faceplate master diagram will be hidden from view.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>(If the Demo project is started) In the IGSS Master, click Home tab &gt; Stop button to stop the Demo project.</td>
</tr>
<tr>
<td>2.</td>
<td>In the IGSS Master, click the Design and Setup tab &gt; Project wizard button to open the Project Wizard.</td>
</tr>
<tr>
<td>3.</td>
<td>In the Project Wizard form, click the Next button and select the Create a new IGSS Project option. Click the Next button.</td>
</tr>
</tbody>
</table>
4. In the **What is the name of the project** field, enter “FaceplateConfig”.

In the **Where should the project files be stored** field, enter “C:\IGSS”. You can click the **Specify Location** button to navigate to the IGSS folder on the C-drive of the local machine.

Select the **Create a sub folder with the project name** check box, click **Next**.

5. Select the **Single User a.k.a. Standalone** option and click **Next**.

6. In the **Unique name for the station** field, enter IGSS_SVR as the server name.

In the **List of Drivers** group, click **New Driver** and select the 7TS7TCP driver (Driver ID 72)

**Create node 0**

- In the **List of Interfaces** group, click **New Interface** to create a new IPNetwork interface.
- In the **List of Nodes** group, click **New Node** to create a new Node 0.
### Exercise 10: Create and deploy Faceplates

#### 7. Create node 1
- In the **List of Interfaces** group, click **New Interface** to create a new IPNetwork interface.
- In the **List of Nodes** group, click **New Node** to create a new Node 1.

#### Create Node 2
- In the **List of Interfaces** group, click **New Interface** to create a new IPNetwork interface.
- In the **List of Nodes** group, click **New Node** to create a new Node 2.

Click the **Finish** button to open the **System Configuration** form.

#### 8. In the left pane of the **System Configuration** form, right-click the IGSS_SVR and select **This PC**.

#### 9. In the right pane of the **System Configuration** form, click the **Data Collection** tab
- In the **Data Collection** group, select the **Run simulated** check box.

#### 10. Close the **System Configuration** form and click **Yes**.

#### 11. In the **IGSS Master** dialog, click the **Yes** button to Check and Deploy the new project.
### Create a new Area

Create the new area for use in the Faceplate project.

In the newly created `FaceplateConfig` project, we need to create a new area to contain the diagrams we are going to create in later exercises.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master &gt; Design and Setup tab, click the Definition button to open the Definition form.</td>
</tr>
<tr>
<td>2.</td>
<td>Click Area and select Create… to open the New Area Properties form.</td>
</tr>
</tbody>
</table>
| 3.   | In the New Area Properties form:  
1) In the Name field, enter “Area01”  
2) In the Default Driver field, select the 7TS7TCP driver  
3) Select the Name to Menu check box |
| 4.   | Click the OK button to create the new area. |

### Create the Main diagram

After the Area01 area has been created, the Main diagram must be created. It will be the entry point for the operators in the Supervise module, and you must remember to ensure that the Main diagram accessible from the Supervise module when IGSS starts.

You will be returning to the Main diagram later to create buttons to open the Instance diagrams you will create later.
# Exercise 10: Create and deploy Faceplates

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Diagram &gt; Create</strong> to open the <strong>New Diagram Properties</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the **New Diagram Properties** form  
   In the **Name** field, enter “Main”  
   Select the **Name to Menu** check box.  
   In the **Background** group, select the **Color** option and click the drop-down menu to open the **Color** form. Select a **light orange** color for the **Main** diagram.  
   In the **Width** field, enter “600”  
   In the **Height** field, enter “300”  
   Click the **OK** button to create the **Main** diagram. |
| 3.   | In the **Definition** form, click **Format > Set Initial Display** to set the **Main** diagram as the default diagram when the Supervise module is opened. |
Create the Faceplate Master diagram

After you have created the **Main** diagram, you can now create the Faceplate **Master** diagram. This will be the diagram all faceplate diagrams are based on. It cannot be used in the monitored process as it will contain Master objects. It is therefore to be hidden from the diagram menu in the Supervise module.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Diagram &gt; Create</strong> to open the <strong>New Diagram Properties</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>New Diagram Properties</strong> form’s <strong>Name</strong> field, enter “FaceplateMaster”. In the <strong>Diagram Type</strong> group, select the <strong>Faceplate Master</strong> option. In the <strong>Background</strong> group, select the <strong>Picture</strong> option and click the <strong>Browse</strong> button to open the <strong>Browse</strong> form. <strong>Note:</strong> If the <strong>Program Data</strong> folder is hidden from view, you can enable display of hidden folders, files and drives on your pc. Click the Microsoft <strong>Start</strong> button, select <strong>Control Panel &gt; Folder Options &gt; View Tab &gt; Hidden files and folders &gt; Show hidden files, folders and drives</strong> option. Navigate to the C:\ProgramData\SchneiderElectric\IGSS32\V13.0\GssDemo\Images\IconsForDemo folder and select the <strong>RefuseDisposalPlant.png</strong> file.</td>
</tr>
<tr>
<td>3.</td>
<td>Click <strong>OK</strong> to create the <strong>FaceplateMaster</strong> diagram, where we will later place a descriptor (a thermometer).</td>
</tr>
</tbody>
</table>
Create object templates

**Purpose**
To create object templates for use on the object list and the faceplate diagrams

**Duration**
20 – 30 minutes.

**Task 1:**
Create new analog and digital object templates

To ensure that the objects in the faceplate diagrams are identical, it is a good idea to base them on object templates.

In this lesson, we will create one analog object template and one digital object template to be used later. The analog object template will use a red thermometer symbol while the digital object template will use black pump symbols.

Note: All alarms, Data Management and PLC mapping settings are reduced to a bare minimum in this lesson as the intent is to create object templates for use in faceplate diagrams.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Template &gt; Create...</strong> to open <strong>Create Template</strong> form.</td>
</tr>
</tbody>
</table>
| 2.   | In the **Create Template** form:  
- In the **Area** field, select **Global**  
- In the **Type** group, select the **Analog** option  
- In the **Name** field, enter “THERMOMETER” (Remember to use CAPITAL letters in the template name)  
- Click the **OK** button to create the Analog object template and open the object properties form for the THERMOMETER template. |
| 3.   | In the **Template Properties** form for the THERMOMETER template for faceplate object properties form, select the **Atom Mapping** tab (see image next page).  
In the **Atom** group select these check boxes:  
- Actual value  
- Set point  
and make sure that all others are NOT selected. |
Exercise 10: Create and deploy Faceplates

In the Atom group, select the Actual Value check box

1) In the Driver field, select the 7TS7TCP driver.
2) In the I/O Mode field, select In
3) In the Driver field, select the 7TS7TCP driver and Node 0
4) In the Data Block number field, in the PLC Address for Actual Value atom group, enter “20”
5) In the Offset field, enter “1”

Select the Set Point check box

1) In the I/O mode field, select Out
2) In the Driver field, select the 7TS7TCP driver.
3) In the Data Block number field, in the PLC Address for Set Point atom group, enter “21”

In the Offset field, enter “1”
4. Click the **Analog** tab:
   - In the **Description** field, enter “Thermometer template for faceplate”
   - In the **Max.** field, enter “500”
   - In the **Min.** field, enter “0”
   - In the **Actual Value** field, enter “110”
   - In the **Set point** field, enter “100”

5. Click the **Data Management** tab
   - In the **Scan interval** group, select the **10000** option.
   - In the **Logging** group, select the **None** check box.
   - In the **Base interval** group, select the **10** option.
   - In the **Data reduction** group, select the **Average, Minimum and Maximum** check boxes.
6. Click the **Symbol Definition** tab, **Symbol Table** field, select **Analog Elements**
   - In the gray symbol bar in the **Choose symbol** group, scroll to the right and select the **Temp** symbol.
   - In the **Choose symbol color** field, select a red color.
   - Select the **Store symbols in template** check box and click the **OK** button to save the analog object template.

Task 2: Create a new pump digital object

The **Pump** digital object template now needs to be created. The **Pump** template will be used to create three identical pump objects for the refuse disposal diagrams.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> form, click <strong>Template &gt; Create...</strong> to open the <strong>Create Template</strong> form.</td>
</tr>
</tbody>
</table>
2. **Create Template Form**

   In the Create Template form, select the Digital option (Global):
   - In the Name field, enter “PUMP” - (Remember to use capital letters in the template name)
   - Click the OK button to create the object template and open the Object Properties form for the PUMP template.

3. **Template Properties: Pump @ Global**

   In the Description field, enter “Pump template for faceplate”

4. **Atom Mapping Tab**

   **Define PLC mapping for Commands**
   - In Atom group, select the Command check box and in the Driver field, select the 7TS7TCP driver.
   - In the PLC Address for Command atom group > Data Block number field, enter “5”

   **Define PLC mapping for States**
   - In Atom group, select the State check box and in the Driver field, select the 7TS7TCP driver.
   - In the PLC Address for State atom group > Data Block field, enter “6”
5. Click the **Data Management** tab > **Scan interval** group select the **2000** option

6. Click **States and Commands** tab.

   **Rename states**

   a) In **State** group, select the **<0** state. In the field to the right, enter “Off” and click the **Add State** button to rename the **<0** state.

   b) In **State** group, select the **1->** state. In the field to the right, enter “On” and click the **Add State** button to rename the **<1** state.

   **Rename commands**

   c) In the **Command** group, select the **0->** command. In the field to the right, enter “Stop” and click **Add Command** to rename the **0->** command.

   d) In the **Command** group, select the **1->** command. In the field to the right, enter “Start” and click **Add Command** to rename the **1->** command.
### Exercise 10: Create and deploy Faceplates

#### IGSS 13 - Configuration Workshop - Exercises

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
</tr>
</thead>
</table>
| 7.   | Click the **Symbol Definition** tab.  
      | **Set symbol for the Off state**  
      | - In the **Digital state for symbol** group, select the **Off** option  
      | - In the **Symbol Table** field, select **Blowers, Compr, Pumps**  
      | - In the gray symbol bar in the **Choose symbol** group, scroll to the right and select the **Pump** symbol.  
      | - In the **Choose symbol color** field, select a dark color, e.g. **black**.  
      | ![Symbol Definition Window](image)  
      | **Set symbol for the On state**  
      | - In the **Digital state for symbol** group, select the **On** option  
      | - In the **Symbol Table** field, select **Blowers, Compr, Pumps**  
      | - In the gray symbol bar in the **Choose symbol** group, scroll to the right and select the **Pump** symbol.  
      | - In the **Choose symbol color** field, select a **green** color.  
      | Select the **Store symbols in template** check box.  
| 8.   | Click the **OK** button to save the digital object template.  

Create Master objects

**Purpose**
The FaceplateMaster diagram can now be populated with the necessary objects. Objects located in the FaceplateMaster can be based on the object templates and made accessible to all faceplates or they can be individual objects designed to be common to all faceplates. Finally, objects specific to the Faceplate Master diagram can be created and placed in the diagram independent of the faceplate.

**NB!** All Master objects must be prefixed with $$ in order to be recognized as Master objects.

**Duration**
10 - 15 minutes.

**Task 1:**
Master objects can now be created based on the objects template you created previously. The objects are then placed in the Faceplate Master diagram.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition form, click Diagram &gt; Open... to open the Object Browser form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the left pane of the Object Browser form, click Area01 &gt; Diagram and select the FaceplateMaster diagram in the right pane. In the Open by name group, make sure the Show properties box is checked. Click the Open/Select button to open the FaceplateMaster diagram.</td>
</tr>
</tbody>
</table>
3. The **Diagram Properties** form opens. Click OK to close the form. The **FaceplateMaster** diagram is now displayed.

   In the **Definition** form, click **Objects > Create > By object type > Analog** to open the **Object Browser** form.

4. In the left pane of the **Object Browser**, click **Area01 > Analog** and select **THERMOMETER**.

5. In the **Name** field, enter “$$t1$$”, click the **Create** button and select **Analog Elements** to display the $$t1$$ Object Properties form.
6. In the **$t1 Object properties** form, select the **Symbol Definition** tab, select the **Inherit symbols from template** check box to transfer the object symbols from the **THERMOMETER** template to the **$t1** object.

7. Click the OK button to create the **$t1** analog master object and place the object in the **FaceplateMaster** diagram.

8. In the **Definition** form, click **Objects > Create > By object type > Digital** to open the **Object Browser** form.

9. In the left pane of the **Object Browser**, click **Area01 > Digital** and select **PUMP**.

10. In the **Name** field, enter “$$p1” and click the **Create** button to display the **$p1** object properties form.

11. Click **$p1 object properties form > Symbol Definition** tab, select the **Inherit symbols from template** check box to transfer the object symbols from the **PUMP** template to the **$p1** object.

12. Click the OK button to create the **$p1** digital master object and place the object in the **FaceplateMaster** diagram.

13. In the **FaceplateMaster** diagram, select the **$p1** object and press **CTRL+C** to copy the **$p1** pump.

14. Press **CTRL+V** to insert the **$p1_1** object and place the object in the **FaceplateMaster** diagram.

15. Press **CTRL+V** to insert the **$p1_2** object and place the object in the **FaceplateMaster** diagram.

16. Click **Diagram > Property Table View** (or press **CTRL+H**) to open the **Property Table View** form,
17. In the left pane of the **Property Table View** form, click **Objects > Standard > Digitals** to display the three digital objects.

- Rename the $\$p_{1\_1}$ pump digital object to $\$p_{2}$
- Rename the $\$p_{1\_2}$ pump digital object to $\$p_{3}$

**Tip:** Scroll right until the **Object name** column, where you can rename.

18. In the left pane of the **Property Table View** form, click **Atoms** to display the atoms of the digital objects.

   a) Find the $\$p_{2} \text{ @ Area01 : Command}$ row and change the value in the **Data group** column to 7
   
   b) Find the $\$p_{2} \text{ @ Area01 : State}$ row and change the value in the **Data group** column to 8
   
   c) Find the $\$p_{3} \text{ @ Area01 : Command}$ row and change the value in the **Data group** column to 9
   
   d) Find the $\$p_{3} \text{ @ Area01 : State}$ row and change the value in the **Data group** column to 10

**Hint:** Filter the atom list to only display atoms for the relevant objects.

Close the **Property Table View** form.
**Exercise 10: Create and deploy Faceplates**

---

**Create common object**

Create an object that is placed in the **FaceplateMaster** diagram and is common to all the faceplates.

**Duration**

10 - 15 minutes.

**Task 2:** Create duty plans

The **Back** button which will open the **Main** diagram needs to be placed in the **FaceplateMaster** diagram.

Since the **Back** button needs to be accessible on all faceplates, it is not necessary to create the **Back** button as a Master object. It is sufficient to create the **Back** button as an ordinary object.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
</table>
| 1.   | In the **FaceplateMaster** diagram, click Objects > Create > By Standard descriptors > Button... to open the **Object Browser** form.  
**Tip:** You can also click the button icon in the Definition tool bar and click in the place in the diagram you want the button. |
| 2.   | In the left pane of the **Object Browser** form, click Area01 > Diagram and select the **Main** diagram. |
| 3.   | Click the **Create** button to open the Main @Area01 **Object Properties** form. |
| 4.   | In the **Main @Area01** properties form, click the **Display** tab and clear the **Name** field in the **Label** group. |
| 5.   | In the **Main @Area01** properties form, click the **Attributes of Button** tab  
In the left pane, click **Style**.  
- In the right pane, in the **Background** color, select an orange color that roughly corresponds with the orange color of the **Main** diagram.  
In the left pane, click **Miscellaneous**.  
- In the right pane, double-click the **Text to be displayed** field and enter “Main” in the **Text to be displayed** form. Click the **OK** button to exit and save the button title text (caption)  
- In the right pane, double-click the **Diagram Navigation** field and click the **Close** button. |
| 6.   | Click the **OK** button to close the **Main @Area01** properties |
| 7.   | Place the **Main** button somewhere convenient in the **FaceplateMaster** diagram. |
Create objects

Purpose
Create the objects that are to be assigned to the master objects and placed on the first faceplate diagram.

Duration
10 - 15 minutes.

Task 3: Create Instance diagrams
The objects that are to be placed on the faceplate diagrams can now be created from the two object templates THERMOMETER and PUMPS:
- RD01_t1 (based on the THERMOMETER analog object template)
- RD01_p1 (based on the PUMPS digital object template)
- RD01_p2 (based on the PUMPS digital object template)
- RD01_p3 (based on the PUMPS digital object template)

The objects must be created as unreferenced objects and are not to be directly placed in any diagram. An object is placed automatically in the faceplate diagram when it is assigned to a Master object in the object list of the Faceplates form.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>FaceplateMaster</strong> diagram, click <strong>File &gt; Object Browser</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
</tbody>
</table>
2. In the left pane of the **Object Browser** form, click **Area01 > Analog > THERMOMETER**.

   In the **Name** field, enter “RD01_t1”

   Click the **Create** button and select **New unreferenced** to open the RD01_t1 object properties form,

   Click the **OK** button to create the RD01_t1 thermometer (analog instance object.)

3. Press **CTRL + E** to open the **Object Browser** form.

   In the left pane of the **Object Browser** form, click **Area01 > Digital > PUMP**.

   In the **Name** field, enter “RD01_p1”

   Click the **Create** button and select **New unreferenced** to open the **RD01_p1 object properties** form.

   ![Object Browser form screenshot](image)

   In the **RD01_p1 object properties** form > **Atom Mapping** tab

   **Define PLC mapping for Commands**
   - In **Atom group**, select the **Command** check box and in the **Driver** field, select the 7TS7TCP driver.
   - In the **PLC Address for Command atom** group > **Data block Number** field, enter “5”

   **Define PLC mapping for States**
   - In **Atom group**, select the **States** check box and in the **Driver** field, select the 7TS7TCP driver.
   - In the **PLC Address for States** atom group > **Data block Number** field, enter “6”

   Click the **OK** button to create the RD01_p1 pump (digital instance object.)
4. Repeat step 3 above for the digital objects RD01_p2 and RD01_p3. Remember to adjust the PLC mapping for the two new pumps.

The RD01_p2 object has the following PLC mapping:
- Commands: Data Block number: 7
- States: Data Block number: 8

The RD01_p3 object has the following PLC mapping:
- Commands: Data Block number: 9
- States: Data Block number: 10

Create the first faceplate diagram

Purpose: Create three faceplate diagrams based on the FaceplateMaster diagram.

Duration: 10 - 15 minutes.

Task 4:
Create Instance diagrams

Create the first of the three faceplate diagrams in the FaceplateMaster diagram and assign the objects to the Master objects in the object list.

The other two faceplates will be created in the next lesson.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the FaceplateMaster diagram, right-click the diagram and select Faceplates... to open the Faceplates form. Click Create to open the Create Faceplate form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the name field, enter “RefuseDisposal01” and click the OK button. The object list for the RefuseDisposal01 now contains the four Master objects that were created for the FaceplateMaster diagram.</td>
</tr>
<tr>
<td>3.</td>
<td>Click the Browse button to open the Object Browser form.</td>
</tr>
</tbody>
</table>
### Exercise 10: Create and deploy Faceplates

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| 4.   | In the left pane of the **Object Browser** form, click **Area01** to display all the objects. The following objects are displayed:  
   - $$t1$$  
   - $$p1$$  
   - $$p2$$  
   - $$p3$$  
   - RD01_t1  
   - RD01_p1  
   - RD01_p2  
   - RD01_p3 |
| 5.   | In the right pane of the **Object Browser** form, select the **RD01_t1** object and drag it precisely into the **Object** column of the object list for the $$t1$$ Master object. The **Object** column will change from **Unassigned** to **RD01_t1@Area01**, indicating that the instance object **RD01_t1** has been assigned to the Master Object placeholder. |
| 6.   | In the right pane of the **Object Browser** form, select the **RD01_p1** object and drag it into the **Object** column of the object list for the $$p1$$ Master object. |
| 7.   | In the right pane of the **Object Browser** form, select the **RD01_p2** object and drag it into the **Object** column of the object list for the $$p2$$ Master object. |
| 8.   | In the right pane of the **Object Browser** form, select the **RD01_p3** object and drag it into the **Object** column of the object list for the $$p3$$ Master object. |
| 9.   | In the **Object Browser** form, click the **Close** button to close the **Object Browser** form. |
| 10.  | In the **Faceplates** form, click the **Close** button to close the **Faceplates** form. |

**Create a button to the first instance diagram**

**Purpose**: Create a button in the **Main** diagram that will open the **RefuseDisposal01** Instance diagram.

**Duration**: 10 - 15 minutes.
Exercise 10: Create and deploy Faceplates

Task 5:
Create a button link to the first faceplate diagram

You can now create a button that will link to the new RefuseDisposal01 faceplate diagram, making it accessible to the operators.

Since the faceplate diagrams are created without adding them to the Diagrams menu in Supervise, you will need to manually provide access to the Instance diagrams for the operators.

In this exercise, you only need to create one button to the RefuseDisposal01 faceplate. Later, you will create buttons for each of the other faceplate diagrams you create.

### Step 1 Action

1. In the Definition form, click Diagram > Open to open the Object Browser form.

### Step 2 Action

2. In left pane of the Object Browser form, click Area01 > Diagram and in the right pane select the Main Diagram.

### Step 3 Action

3. Click the Open/Select button to open the Main diagram in the Definition module. Click OK to close the Diagram Properties form.

### Step 4 Action

4. In the Main diagram, right-click and select New > Standard descriptors > Button... to open the Object Browser form.

### Step 5 Action

5. Click Area01 > Faceplate, select the Refusedisposal01 faceplate diagram in the right pane.
   
   Click Create to open the Refusedisposal01 @Area01 Object Properties form.

### Step 6 Action

6. Click the Display tab and clear the Name check box field in the Label sub-group.

### Step 7 Action

7. Click the Attributes of Button tab.
   
   In the left pane, click Style.
   
   - In the right pane, in the Background color, select a green color.
   
   In the left pane, click Miscellaneous.
   
   - In the right pane, double-click the Text to be displayed field and enter “Refuse Disposal01” in the Text to be displayed form. Click the OK button to exit and save the button title text (caption)
   
   - In the right pane, double-click the Diagram Navigation field and click the Close button.

### Step 8 Action

8. Click OK to close the Refusedisposal01 @Area01 properties form. The new green button is now created.

### Step 9 Action

9. Place the Refuse Disposal01 button the desired place in the Main diagram.
Create the rest of the faceplates

**Purpose**
Create two more faceplate diagrams based on the FaceplateMaster diagram by copying the first faceplate diagram and renaming the objects.

**Duration**
30 - 45 minutes.

**Task 1:**
Create remaining Instance diagrams

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition form, click Diagram &gt; Open to open the Object Browser form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the left pane of the Object Browser form, click Area01 &gt; Diagram and select the FaceplateMaster diagram in the right pane. Click the Open/Select button to open the FaceplateMaster diagram and the Diagram Properties form. Click OK or Cancel to close the form.</td>
</tr>
<tr>
<td>3.</td>
<td>In the FaceplateMaster diagram, right-click in the diagram and select Faceplates to open the Faceplates form.</td>
</tr>
</tbody>
</table>
| 4.   | In the Faceplates form > Faceplate field, select “RefuseDisposal01” and click the Copy button to open the Copy Faceplates Objects form. In the name field, enter “RefuseDisposal02” and select the Copy Objects check box. Click the OK button to create the object list for the RefuseDisposal02 as a copy of the object list for the RefuseDisposal01 with the new objects:  
  - RD01_t1_1  
  - RD01_p1_1  
  - RD01_p2_1  
  - RD01_p3_1  

Click the Close button to close the Faceplates form.
5. Rename the objects on the object list of the RefuseDisposal02 faceplate.
   In the Definition main menu, click Area > Property table View to open the Property Table View form for the active area.
   Tip: You can also press CTRL + SHIFT + H to open the Property Table View form.

6. In the left pane of the Property Table View form, click + Objects > Standard > Analogs and locate the RD01_t1_1 object.
   Scroll right to locate the Object name column and rename the object to RD02_t1

7. In the left pane of the form, click Objects > Standard > Digitals.
   In the Filter row of the Object name column, double-click, write “*_1” and press Enter to find all the new digital objects.
   Rename the objects as follows:
   - RD01_p1_1 is renamed to RD02_p1
   - RD01_p2_1 is renamed to RD02_p2
   - RD01_p3_1 is renamed to RD02_p3

8. In the left pane of the form, click Atoms
   In the Filter row of the Object name column, double-click, write “RD02*” and press Enter to find all the new objects.
   In the Filter row of the Defined column, enter “Yes*” to find all the defined atoms of the RD02 objects.
   In the Node column, change the node to “1” and press Enter.
   NB! Pay close attention and see what happens in the row below .....
9. Close the **Property Table View** form.

10. Repeat the exercise **from step 3** for the last of the faceplate diagrams; name the third faceplate diagram **RefuseDisposition03** and rename the objects as follows:

- RD01_t1_1 is renamed to RD03_t1
- RD01_p1_1 is renamed to RD03_p1
- RD01_p2_1 is renamed to RD03_p2
- RD01_p3_1 is renamed to RD03_p3

Change the node for object on the RefuseDisposition03 diagram to “2” when you get to step 8.

---

### Create a button to the rest of the faceplate diagrams

**Purpose**
Create a button in the **Main** diagram that will open the **RefuseDisposition02** and **RefuseDisposition03** Instance diagram.

**Duration**
10 - 15 minutes.

**Task 2:**
Create a button to the other instance diagrams

The Main diagram contains a button linking to the **RefuseDisposition01** Instance diagram.

You can now modify the **Main** diagram by adding buttons to link the remainder of the Instance diagrams: **RefuseDisposition02** and **RefuseDisposition03**.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>Definition</strong> menu, click <strong>Diagram &gt; Open</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>In left pane of the <strong>Object Browser</strong> form, click <strong>Area01 &gt; Diagram</strong>, select the <strong>Main</strong> Diagram in the right pane and click <strong>OK</strong> to close the <strong>Diagram Properties</strong> form.</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Main</strong> diagram, select the <strong>Refuse Disposal 01</strong> button and press <strong>CTRL + C</strong> and <strong>CTRL+ V</strong> to create a copy of the <strong>Refuse Disposal 01</strong> button. Place the copy of the <strong>Refuse Disposal 01</strong> button in the <strong>Main</strong> diagram</td>
</tr>
<tr>
<td>4.</td>
<td>Right-click the copy of the <strong>Refuse Disposal 01</strong> button and select <strong>Reconnect</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>5.</td>
<td>In the right pane of the form, select the <strong>Refusedisposal02</strong> and click <strong>Open/Select</strong> to connect the button to the <strong>Refusedisposal02</strong> diagram and close the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>6.</td>
<td>Right-click the copy of the <strong>Refusedisposal01</strong> button and select <strong>Properties</strong> to open the <strong>Refusedisposal02@Area01</strong> properties form.</td>
</tr>
</tbody>
</table>
7. In the Refusedisposal02@Area01 properties form, click the Attributes of Button tab.
   In the left pane, click Style.
   - In the right pane, in the Background color, select a green color.
   In the left pane, click Miscellaneous.
   - In the right pane, double-click the Text to be displayed field and enter “Refuse Disposal 02” in the Text to be displayed form. Click the OK button to exit and save the button title text (caption)
   - In the right pane, double-click the Diagram Navigation field and click the Close button.

8. Click the OK button to close the Refusedisposal02@Area01 properties.

9. Repeat the steps to create a button for the RefuseDisposal03 Instance diagram.

---

**Test the faceplate diagram**

**Purpose**
Install the project and run the Main diagram as an operator in Supervise.

**Duration**
10 - 15 minutes.

**Task 3:**
Check and Deploy the project and close the Definition form. Once the project has been installed, start the project, open the Supervise module and click the buttons in the Main diagram.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition menu, click Files &gt; Check and Deploy.... When the project has been installed, close the Definition module and open the IGSS Master.</td>
</tr>
<tr>
<td>2.</td>
<td>In the IGSS Master module, click Home tab &gt; Start to start the FaceplateConfig project in the Supervise module. The Main diagram will also be displayed.</td>
</tr>
<tr>
<td>3.</td>
<td>In the Main diagram, click the buttons that display the instance diagrams and manipulate the objects.</td>
</tr>
</tbody>
</table>
Faceplates – Additional exercises (Optional)

**Add a common image file to the Faceplate Master diagram**

**Purpose**
Add a common descriptor (an image that symbolizes a power grid) to the Faceplate Master diagram, connect it to an object (t1 Temperature in burner) and see how all the faceplates are updated to display the image.

**Duration**
10 - 15 minutes.

**Task 1:**
Open the Faceplate Master diagram and insert a .png image in the Faceplate Master diagram. The image will be present and displayed in all the associated faceplate diagrams as a common object.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>IGSS Master &gt; Home</strong> tab, click the <strong>Stop</strong> button to stop supervise. When the project has stopped, continue to step 2.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>IGSS Master &gt; Design and Setup</strong> tab, click the <strong>Definition</strong> button to open the <strong>Definition</strong> module.</td>
</tr>
<tr>
<td>3.</td>
<td>In the <strong>Definition</strong> form, click <strong>Diagram &gt; Open</strong> to open the <strong>Object Browser</strong> form.</td>
</tr>
<tr>
<td>4.</td>
<td>In the left pane of the <strong>Object Browser</strong> form, click <strong>Area01 &gt; Diagram</strong> and select the <strong>FaceplateMaster</strong> diagram in the right pane. Click the <strong>Open/Select</strong> button to open the <strong>FaceplateMaster</strong> diagram.</td>
</tr>
<tr>
<td>5.</td>
<td>In the <strong>Definition module</strong> diagram, click <strong>View &gt; Drawing Toolbar</strong>.</td>
</tr>
<tr>
<td>6.</td>
<td>In the <strong>Drawing</strong> Toolbar, select the <strong>Image</strong> ( ) button Click in <strong>FaceplateMaster</strong> diagram where you want to place the image.</td>
</tr>
<tr>
<td>7.</td>
<td>In the <strong>Open an Image File</strong> form, browse to the <strong>Power_Grid.png</strong> found on the USB or in C:\ProgramData\Schneider Electric\GSS32\V13.0\GssDemo\Images.</td>
</tr>
<tr>
<td>8.</td>
<td>In the <strong>Open an Image File</strong> form, select the <strong>Power_Grid.png</strong> file and click <strong>OK</strong> to insert the image in the <strong>FaceplateMaster</strong> diagram. Place the image in the top right corner of the <strong>FaceplateMaster</strong> diagram:</td>
</tr>
</tbody>
</table>
Exercise 10: Create and deploy Faceplates

9. Right-click the Power_Grid.png image and select Connect.

10. In Object Browser, find the t1 Temperature in burner and click Open/Select.

11. In t1 Object Properties form’s Attributes of Image tab, under Geometry, enter Size of alarm border.

   Under Bindings to Object Alarms, double-click Flash on color and select a Red color. Click OK to close the form.

12. In the Definition form, click File > Check and Deploy (or press CTRL + T) to Check and Deploy your Faceplate diagram and test in Supervise.

---

**Embed a faceplate diagram in an image**

**Purpose**
In the Main diagram, embed a faceplate diagram in an image and link the faceplate diagram.

**Duration**
10 - 15 minutes.

**Task 1:**
Use an image to link to a faceplate diagram

Previously, you created three buttons in the Main diagram to open a faceplate diagram each.

You will now insert an image that will display the Refuse Disposal 03 diagram and provide a link to the diagram.

Objects on the Refuse Disposal 03 diagram will be displayed in the embedded image and are accessible in the embedded image from the Main diagram.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master &gt; Home tab, click the Stop button to stop supervise. When the project has stopped, continue to step 2.</td>
</tr>
<tr>
<td>2.</td>
<td>In the IGSS Master &gt; Design and Setup tab, click the Definition button to open the Definition module.</td>
</tr>
<tr>
<td>3.</td>
<td>In the Definition form, click Diagram &gt; Open to open the Object Browser form.</td>
</tr>
</tbody>
</table>
4. In the left pane of the **Object Browser** form, click **Area01 > Diagram** and select the **Main** diagram in the right pane.

Click the **Open/Select** button to open the **Main** diagram.

5. In **Main** diagram, right-click and select **New > Standard Descriptors > Image** to display the **Object Browser** form.

6. In the left pane of the **Object Browser** form, click **Area01 > Faceplate** and select the **RefuseDisposal03** faceplate diagram in the right pane.

Click the **Create** button to open the **Open an Image File** form and close the **Object Browser** form.
### Exercise 10: Create and deploy Faceplates

7. In the **Open an Image File** form, browse to the C:\ProgramData\Schneider Electric\IGSS32\V13.0\GssDemo\Images\ folder and select the **RefuseDisposal.png** file.

   Click the **Open** button to create the image in the **Main** diagram and close the **Open an Image File** form.

![Image of Main diagram with RefuseDisposal.png]

8. Place the image in the **Main** diagram and re-size as you require.

   Right-click the image and select **Properties** to open the **Object Properties** form.

9. In the **Display** tab of the **Object Properties** form, clear the **Name** check box in the **Label** sub-group.

![Object Properties form with RefuseDisposal03\@Area01]

10. Click **OK** to save and close the **Object Properties** form.

11. **Check and Deploy** your project and test in **Supervise**.

### Optional 1

You can also do the exercise again, inserting a rectangular field in Step 5 above instead of an image.

### Optional 2

You can also do the exercise again, inserting a **Rectangle** in Step 5 above instead of an image.
Exercise 11: Using Notifier

Contents: Setting up Notifier and getting alarms.
Duration: 20 - 30 minutes.

Start the Demo Project

Purpose: The IGSS project we will use is the **Demo project** which is installed automatically when the “Demo system” option is selected during installation of IGSS.

Task 1: Load and start the Demo project

Now let’s go online with the Demo project.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.</td>
<td>Start IGSS from the Start menu in Windows or click the IGSS icon on the Windows desktop. The <strong>IGSS Master</strong> opens.</td>
</tr>
<tr>
<td>5.</td>
<td>In the <strong>IGSS Master</strong>, click the Start button.</td>
</tr>
<tr>
<td>6.</td>
<td>When IGSS is running select the Design and Setup tab and click the System Configuration button.</td>
</tr>
<tr>
<td>7.</td>
<td>Start <strong>Sysconfig</strong> and click the Access Control tab.</td>
</tr>
</tbody>
</table>

In the Notifier Server settings group, click **Add**.
Exercise 11: Using Notifier

### Configuration of Notifier

**Purpose**
To learn how to configure Notifier.

**Task 1:**
We need to locate the Notifier program in IGSS Master.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In IGSS Master select the <strong>Home</strong> tab and click the <strong>Notifier</strong> button.</td>
</tr>
</tbody>
</table>
| 2.   | In Notifier, select the **Configuration** tab.  
Click the **Add Server Station** button in the top menu.  
In the Server Configuration form click Add next to **Server station name** and select server.  
Under **Login Information** enter the use user name and password you defined in Sysconfig.  
Add an **Operator**, with a phone number. Make sure her/she is available for duty planning. |
| 3.   | Look in the **Event log** to see the status of Notifier. |
4. If no errors, click **Alarm View**. Here you can see IGSS Alarms with the **To Notifier** check mark.

![Image of Alarm View]

5. Select the **Duty Planner** and the **Duty Calendar** tabs.

Create a **New Duty** for today from 00.00 to 08.00. There are two ways to do this.

- Fill in the **Name**, **Start** and **End times** at the top of the **Duty Planner** and click the round green **Create duty plan** icon, or ….

- … Right-click the calendar on the actual date and time and select **Create**.

![Image of Duty Planner and Calendar]

Place the cursor in the New duty area where the cursor becomes a ⬇️ symbol. Drag it down till the desired end time.

6. To add an **Operator**, right-click inside the duty area.

Select **Add operator > Primary** and the relevant operator.

![Image of Operator Selection]
7. Set up the Operator to be on duty all Weekdays from 8 to 16.
   a) Click on the first day of the new duty
   b) Click the round Duty Recurrence (recycling) icon in the top menu.
   c) In the duty recurrence form, fill in the Duty time and click OK.

8. Create 4 new operators. One of them is yourself.

9. Make Operator 1 on Duty weekdays from 00.00 to 08:00.
   Make Operator 2 on Duty weekdays from 08.00 to 16:00.
   Make Operator 3 on Duty weekdays from 16.00 to 00:00.
   Make Operator 4 on Duty weekends.
   Your calendar is full. Click File Save.

Task 2: Create Calendars as the 4 Operators cannot work like this every day 365 days a year.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In Notifier, select the Configuration tab and click the Calendars Icon.</td>
</tr>
</tbody>
</table>
2. Create a new IGSS calendar called: “IGSS Configuration Workshop”.
   Click the **Add** button and press **OK**. (Do not activate it yet)

![Calendar Settings](image1)

3. In the **Configuration** tab add 2 new operators.
   ![Operator Settings](image2)
   **Tip:** You can do this independent of which sub-tab (Duty Calendar, Alarm View etc.) is active.

4. Select the **Duty Planner** tab and change the active calendar to the new **IGSS Configuration Workshop** calendar.
   ![Duty Planner](image3)
5. Create a new duty and add the 2 new operators to be on duty 24/7 or how you see fit as described in task 1 step 5.

Instead of right-clicking the new duty in the calendar (task 1) to add operators, you can also use the Add Operator icon in the Duty Planners main menu.

6. Create a new Calendar called “Normal” in the Configuration tab as described in step 1 and 2 above.

7. Go to the Duty Planner tab and select the Duty Calendar tab. In the drop down menu select the Main Calendar.

Right-click to move the 4 operators you first created to the calendar Normal.

8. Got to the Configuration tab. Click Calendars. Under Activation, click Add >> to move the IGSS Configuration Workshop calendar from Inactive to the Active.

You are now free to attend the 3 days IGSS Configuration Workshop. The 2 other operators are taking care of your alarms 😊.
Exercise 12: Create Users & User Privileges; Lock project

**Purpose**
Learn how to create new user groups, define their rights and assign users to the groups using the User Administration module. You will also protect objects in the Definition module so only users with defined rights are allowed to operate them. In IGSS Master you will enable project locking to prevent more users from making changes at the same time. Finally, you set safe commands on objects (optional).

In this exercise, you will be using the IGSS Demo project again.

**Duration**
20 - 25 minutes.

You are to create three user groups but only need to create one user for each user group. The three user groups are:

- **Admin**: All the system administrators and supervisors, regardless of day or night shift.
- **OpDay**: System Operators, Day shift
- **OpNight**: System Operators, Night shift

The table below displays the users, user groups and rights you need to set up in this exercise.

<table>
<thead>
<tr>
<th>User Administration Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>User group</strong></td>
</tr>
<tr>
<td>Global rights</td>
</tr>
<tr>
<td>Protect object rights</td>
</tr>
<tr>
<td>Default diagrams</td>
</tr>
<tr>
<td>User name</td>
</tr>
<tr>
<td>Password</td>
</tr>
</tbody>
</table>

**Task 1: Create User groups**
You must first create the user groups in order to assign the users to the groups. You will later define the Protect Object security settings and create the users.
**Exercise 12: Create Users & User Privileges; Lock project**

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click the <strong>Design and Setup</strong> tab &gt; <strong>User Administration</strong> button to open the <strong>User Administration</strong> tab in the IGSS Master workspace.</td>
</tr>
</tbody>
</table>

![IGSS Master workspace](image)

| 2.   | In the **User Administration** tab, click the **Groups** tab. |

| 3.   | **Create the Admin user group**<br>1) In the **Groups** tab, click the **Add New** button.<br>2) In the **Group Name** field, enter “Admin”<br>3) In the **Area** field, select **Global** (even if already shown!)<br>4) In the **Diagrams** group, select the **Home** check box<br>5) In the **Permissions** group, select the following check boxes:<br>a. Can administer<br>b. Can define<br>c. Can define **WinPager** settings (Legacy)<br>d. Can edit maintenance jobs<br>e. Can use IGSS Mobile<br>f. Can use system commands<br>g. **Protect@Global: Level 4** check box<br>6) Click the **Commit** button to save the user group. |

![User Administration tab](image)
4. Create the **System Designer** user group:
   1) In the **Groups** tab, click the **Add New** button.
   2) In the **Group Name** field, enter “**Designer**”
   3) In the **Area** field, select **Global** (even if already shown!)
   4) In the **Diagrams** group, select the **Home** check box
   5) In the **Permissions** group, select the following check boxes:
      - Can define
      - Can define **WinPager** settings (Legacy)
      - Can edit maintenance jobs
      - Can use IGSS Mobile
      - Can use system commands
      - **Protect@Global: Level 3** check box
   6) Click the **Commit** button to save the user group.

5. Create the **OpDay** user group:
   1) In the **Groups** tab, click the **Add New** button.
   2) In the **Group Name** field, enter “**OpDay**”
   3) In the **Area** field, select **Training**
   4) In the **Diagrams** group, select the **WasteWater** check box
   5) In the **Permissions** group:
      a. Select the **Can use systems commands** check box
      b. Select the **Can use IGSS Mobile** check box
      c. Select the **Protect@Global: Level 2** check box
   6) Click the **Commit** button to save the user group.
Exercise 12: Create Users & User Privileges; Lock project

6. Create the **OpNight** user group:
   1) In the **Groups** tab, click the **Add New** button.
   2) In the **Group Name** field, enter “**OpNight**”
   3) In the **Area** field, select **Global**
   4) In the **Diagrams** group, select the **Home & IGSS Mobile** check boxes
   5) In the **Permissions** group, select the **Can use IGSS Mobile** and **Protect@Global: Level 1** check boxes. All other boxes should be cleared.
   6) Click the **Commit** button to save the user group.

**Task 2:**

**Setting up the Protect object rights**

Now we must set up the various Protect object levels to be used on individual objects in our project.

The Protect object is a digital object where only one state can be active. So only level 1, 2, 3 or 4 can be the active protect level unless you select the **Hierarchical** check box for the relevant protect levels.

When you select the **Hierarchical** check box, you simulate that multiple security levels are active at the same time.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click <strong>Design and Setup</strong> tab &gt; <strong>Definition</strong> button.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Definition</strong> module, click <strong>File &gt; Object Browser</strong> (or press <strong>CTRL + E</strong>) to open the <strong>Object Browser</strong> form.</td>
</tr>
</tbody>
</table>
| 3.   | In the **Object Browser**, find the **Protect** digital object (screen dump next page).  
   1) In the **Wild card text criteria** field, enter “Protect”  
   2) In the right pane of the **Object Browser** form, select the **Protect** object  
   3) In the **Open by Name** field group, select the **Show Properties** check box  
   4) Click **Open / Select** to open the Protect object **Object Properties** form |
4. In the **Object Properties** form (see next page) for the Protect object, click the **Command/State Config** tab.

5. In the **States** group, select **Security level 4**.
   In the **Protect Object** rights field group, select the **Hierarchial** check box.
   In the **Permissions** field group, select all the check boxes.
   In the Protect Object rights field group, select the Hierarchical check box.
   In the Permissions field group, select only these check boxes:
   - Can update set points
   - Can update alarm limits
   - Can send commands
   - Can acknowledge alarms

   In the Protect Object rights field group, select the Hierarchical check box.
   In the Permissions field group, select only these check boxes:
   - Can update set points
   - Can update alarm limits
   - Can acknowledge alarms

8. In the States group, select Security level 1.
   In the Permissions field group, select only this check box:
   - Can acknowledge alarms

9. After you have set up the security levels for the Protect object, you must enable the Protect object, setting the maximum level of security the Protect object can assume.
   In the Object Properties form for the Protect form, click the Digital tab.

10. In the States group, select Security level 4

11. Click OK to save the Protect object settings and close the form.

12. In the Definition module, click File > Check and Deploy (or press CTRL+T) to install the project with the new Protect object changes.
Task 3: Create and assign users to user groups

After you have set up the Protect object levels to be used on individual objects in our project, you must create the users and their passwords and assign the users to the relevant user groups.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click the Design and Setup tab &gt; User Administration button to open the User Administration tab in the IGSS Master workspace.</td>
</tr>
<tr>
<td>2.</td>
<td>In the User Administration tab, click the Users tab.</td>
</tr>
<tr>
<td>3.</td>
<td>Create the Admin user:</td>
</tr>
<tr>
<td></td>
<td>1) In the Users tab, click the Add New button.</td>
</tr>
<tr>
<td></td>
<td>2) In the User Identification field, enter “Admin”</td>
</tr>
<tr>
<td></td>
<td>3) In the Password field, clear the field and enter “admin”</td>
</tr>
<tr>
<td></td>
<td>4) In the Full name field, enter “Administrator”</td>
</tr>
<tr>
<td></td>
<td>5) In the Group membership group box, select Admin user group</td>
</tr>
<tr>
<td></td>
<td>6) Click the Commit button to save the user group.</td>
</tr>
</tbody>
</table>
4. Create the **Designer1** user:
   1) In the **Users** tab, click the **Add New** button.
   2) In the **User Identification** field, enter “**Designer1**”
   3) In the **Password** field, clear the field and enter “**design1**”
   4) In the **Full name** field, enter “**System designer 1**”
   5) In the **Group membership** group box, select the **Designer** user group.
   6) Click **Commit** to save the user.

5. Create the **Designer2** user in the same way as described above.

6. Create the **UserDay** user:
   1) In the **Users** tab, click the **Add New** button.
   2) In the **User Identification** field, enter “**UserDay**”
   3) In the **Password** field, clear the field and enter “**day**”
   4) In the **Full name** field, enter “**User Day Shift**”
   5) In the **Group membership** group box, select the **OpDay** user group
   6) Click the **Commit** button to save the user group.

7. Create the **UserN** user:
   1) In the **Users** tab, click the **Add New** button.
   2) In the **User Identification** field, enter “**UserN**”
   3) In the **Password** field, clear the field and enter “**night**”
   4) In the **Full name** field, enter “**User Night Shift**”
   5) In the **Group membership** group box, select the **OpNight** user group
   6) Click the **Commit** button to save the user group.

**Note:** Only use short user names as you can only set user names of up to 8 characters. The user name is case-sensitive: “UserDay” is not the same user as “userday”. Passwords are also case-sensitive.
Exercise 12: Create Users & User Privileges; Lock project

Task 4: Connect the “Protect object” to project objects to be protected

After you have set the security settings for the Protect object, you must now ensure the special Protect object is connected to the objects in the project for which we need extra security.

You will set up object-level security for the p3 digital object (water pump) in the Refuse Disposal project and for the q3 analog object (flow tank 1) in the Dairy project.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the Definition module, double-click IGSS training button &gt; Refuse Disposal image to open the Refuse Disposal diagram. You can also click Area &gt; Training and then Diagram &gt; Refuse disposal to open the Refuse Disposal diagram.</td>
</tr>
<tr>
<td>2.</td>
<td>In the Refuse Disposal diagram, locate the p3 digital object (water pump) On the p3 digital object, right-click and select Properties to open the p3 – Water pump form.</td>
</tr>
<tr>
<td>3.</td>
<td>In the p3 – Water pump form, click the Data Management tab. In the Protection field, select Protect in the drop-down box.</td>
</tr>
</tbody>
</table>
Exercise 12: Create Users & User Privileges; Lock project

4. Click the OK button to save the properties and exit the p3 – Water pump form.

5. In the Refuse Disposal diagram, click Area > Training and then Diagram > Dairy to open the Dairy diagram.

6. In the Dairy diagram, locate the q3 analog object (q3 Flow Tank 1).
   On the q3 analog object, right-click and select Properties to open the q3 Flow Tank 1 form.
   Tip
   You can use the Object Browser form (Found in File > Object Browser) to search for and find the q3 analog object.

7. In the q3 Flow Tank 1 form, click the Data Management tab.
   In the Protection field, select Protect in the drop-down box.

8. Click the OK button to save the properties and exit the q3 Flow Tank 1 form.

9. In the Definition menu, click File > Check and Deploy to install the changes you have made. Click File > Exit to close Definition before you do next exercise.

Task 5:
Enable User Administration
User access control must be enabled for the user log on and object-level security to take effect in the project.
You can enable user access control from the IGSS Master in the System Configuration form. The access control system is disabled by in IGSS.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click Design and Setup tab &gt; System Configuration button to open the System Configuration form. Select the DemoStation.</td>
</tr>
<tr>
<td>2.</td>
<td>In the System Configuration form, click the Access Control tab.</td>
</tr>
<tr>
<td></td>
<td>- Clear the Disable access control check box.</td>
</tr>
<tr>
<td></td>
<td>- Select the Allow permanent user login check box.</td>
</tr>
<tr>
<td></td>
<td>- Select the Save latest user logged in check box.</td>
</tr>
</tbody>
</table>
3. Click the **Supervise & Language** tab.

   In the **Options** group, select the **Show active user name in status bar** check box.

4. Click the **Startup** tab. In the **Startup** group, select the **Manual** option.

5. Click the **File > Save and Exit**.

6. Allow the system to re-start the **IGSS Master** and the demo project.

**Task 6: Test with User administration enabled**

Test the user profiles **UserDay** and **UserN** in the Demo project, **Training** diagrams.

You will log on as **UserN** and attempt to adjust the values of the **p3** and **q3** objects in the **Dairy** and **Refuse Disposal** diagrams.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In <strong>IGSS Master</strong>, click the <strong>Home Tab &gt; Stop button</strong>. When the project has stopped, start the project again.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Temporary Login</strong> dialog, log in as <strong>UserN</strong> and “<strong>night</strong>” Verify that the User <strong>UserN does not</strong> have sufficient security rights to start the project.</td>
</tr>
<tr>
<td>Exercise 12: Create Users &amp; User Privileges; Lock project</td>
<td></td>
</tr>
<tr>
<td>----------------------------------------------------------</td>
<td></td>
</tr>
</tbody>
</table>

3. In the **Temporary Login** dialog, log in as **UserDay** and “day” who has sufficient security rights start the project.

   Select **Keep the user logged in** – if not, the login is only valid for 1 action.

   **Tip:** You can also **Login in IGSS Master’s Home tab**, for permanent login.

4. In **IGSS Master**, click > **Home tab > Supervise button**.

5. Verify that the **WasteWater** diagram is be opened.

   Click **File > Logout** to log out as **UserDay**.

6. In the **WasteWater** diagram, click **File > Login** and log in as **UserN**

7. Verify that the **Home** area is displayed and click the **IGSS Training diagram**.

8. In the **IGSS Training** diagram, open the **Refuse Disposal** sub-diagram.
9. In the Refuse Disposal diagram, click STOP under the p3 object (Water pump).

Verify that the Temporary login dialog is displayed and you DO NOT as UserN have sufficient security rights to stop the p3 object (pump).

What happens?

Log in temporarily as UserDay and Admin. Who has the right to control the pump?

10. Click Back to open the Training diagram. Select the Dairy Production diagram.

11. In the Dairy diagram, locate the q3 analog object (Flow tank 1).

Right-click the object q3, select HA (High Alarm) and change the HA limit to “85”.

Verify that the UserN does NOT have sufficient security rights to change the alarm settings on the q3 object (water tank 1).

12. Click File > Logout to log out as UserN. Click File > Log in and log in as UserDay.

13. Verify that the Pump Station diagram is displayed. Click the Back button to open the Training Diagram. Open the Dairy Production diagram.

14. In the Dairy diagram, locate the q3 object.

Right-click the q3 object and select Acknowledge alarm.

15. In Dairy diagram, click File > Exit to return to the IGSS Master.
**Exercise 12: Create Users & User Privileges; Lock project**

---

**Task 7: Set Safe commands on objects**

*This exercise is optional.* Complete this exercise only if you completed the previous exercises and there is surplus time to do this exercise.

You need to set safe commands on the two p1 and p2 water pumps in the Dairy diagrams, defining different settings for the water pumps.

In order to test the safe command set up, you will need to create an extra user and assign membership of the OpDay user group as well as change the default diagram for the OpDay user group.

First you have to log on as Admin in order to access User Administration.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click Home tab &gt; Logout to log out as the present user (Use Day from above).</td>
</tr>
</tbody>
</table>

Click the Home tab > Login and log in as Admin.

Verify that the Admin user icon is displayed in the lower right hand corner of IGSS Master.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>2.</td>
<td>In the IGSS Master, click the Design and Setup Tab &gt; User Administration button to open the User Administration tab.</td>
</tr>
</tbody>
</table>

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>3.</td>
<td>In the Groups tab:</td>
</tr>
</tbody>
</table>

1) In the User Group drop down menu, select the OpDay group.
2) In the Area field, select Training – also if it is already visible
3) In the Diagrams field, select the Refuse check box.
4) Click Commit

---
4. In the **Users** tab (see next page), create the new user as described in **task 3**:
   - **User**: UserDay2
   - **Password**: day2
   - **Group Membership**: OpDay.

5. In the **IGSS Master**, click **Design and Setup** and open the **Definition** module.

6. In the **Definition** form, double-click **IGSS Training button > Refuse Disposal** image to open the **Refuse Disposal** Diagram.

7. In the **Refuse Disposal** Diagram, locate and right-click the p1 digital object. Select **Properties** to open the **p1 – Pump water** form. Click the **Data Management** tab.

8. In the **Data Management** tab:
   1. **Safe Commands** field, select **Confirm**
   2. **Protect** field, select **(Unused)** to remove any object level protections for the p1 object.
   3. Click the **OK** button to exit the **p1 – Pump water** form.

9. In the **Refuse Disposal** Diagram, locate and right-click the p2 digital object. Select **Properties** to open the **p2 – Pump water** form and click the **Data Management** tab.
10. In the Data Management tab:
   1) Safe Commands field, select **Enter Password**
   2) Protect field, select **(Unused)** to remove any object level protections for the p1 object.
   3) Click the OK button to exit the p2 – Pump water form.

11. In the Refuse Disposal Diagram, locate and right-click the p3 digital object.
    Select Properties to open the p3 – Pump water form and click the Data Management tab.

12. In the Data Management tab:
    1) Safe Commands field, select **Password from 2 users**
    2) Protect field, select **(Unused)** to remove any object level protections for the p1 object.
    3) Click the OK button to exit the p3 – Pump water form.

   **Note**
   The object-level protection on the p3 object is still active.

   To test the combination of Object-level protection and Safe commands, log on as UserN after this exercise and try to change the value of the p3 digital object.

13. In the Refuse Disposal diagram, click File > Check and Deploy to implement your changes and exit the Refuse Disposal diagram.

14. In the IGSS Master, click Home tab > Logout to log out as the Admin
    In the IGSS Master, click Home tab > Login and log in as UserDay.

15. In the IGSS Master, click Home > Supervise to open the Refuse Disposal diagram.

16. In the Refuse Disposal diagram, change the value of the p1 object.
    Verify a dialog box is displayed prompting you to accept the change.

17. In the Refuse Disposal diagram, change the value of the p2 object.
    Verify a dialog box is displayed prompting for your password in order to accept the change.

18. In the Refuse Disposal diagram, change the value of the p3 object.
    Verify a dialog box is displayed prompting for your password and another user’s password to accept the change in the Performed by group.
    Use the user UserDay2 to fill out the Verified by group and accept the change.

19. In the Refuse Disposal diagram, click File > Exit to return to the IGSS Master
Exercise 12: Create Users & User Privileges; Lock project

20. (Optional step – compressed instructions)

You can quickly reset the Safe Commands settings in the p1, p2 and p3 digital objects by using the **Property Table view**. In **Definition**, right-click the **Refuse Disposal** diagram and select **Property Table view**.

In the left pane in the **Objects** folder, select the p1, p2 and p3 digital objects and change the value in the **Safe Command** column to “(None)”.

Remember to log on as Admin if you are going to open the **Definition** form.

---

**Task 8:**
**Lock a project** (Optional)

It is possible for a system designer to lock a project during the design phase to prevent that others can work in an already open project, thus eliminating the risk of having more simultaneous versions of the same project.

Project locking is enabled in **IGSS Master’s System Configuration**. It also requires enabled Access control and defined users and user groups as we have done now.

Locking and unlocking of specific projects is also done in **IGSS Master**.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td><strong>Enable Project locking (System Administrator).</strong></td>
</tr>
</tbody>
</table>

In **IGSS Master’s Home** tab, make sure that IGSS is stopped. Click the **Login** icon and logon as administrator (User: **Admin** – Password: **admin**). Click **OK**.

Tip! The status bar at the bottom of your screen now shows the user logged on.
2. Select the **Design and Setup** tab and click the **System Configuration** icon.

3. In the left pane of the **System Configuration** form, mark the name of the project – in this case **Demo** - for which you want to make it possible for system designers to lock and unlock projects.

   Select the box “**Enable Project Locking**”. Click **File > Save and Exit**.

4. Go to the **Home** tab and click the **Logout** icon.

5. **Lock a project (System designer)**

   Click the **Login** icon again to gain access as a system designer. When prompted logon, enter:
   - **User**: Designer1
   - **Password**: design1

6. In the **Design and Setup** tab, click the **Definition** icon to open the module.

   A message now tells you that you haven’t locked the project.

   You first have to lock the project, before you can work on it in **Definition** (because project locking is enabled).

   Click **No** to close the dialogue.
7. In the Design and Setup tab’s Status pane, it says “Project is unlocked”. Click the Lock icon to lock the project. You have now locked the project.

Click the Definition icon to check that you have access to work on the project. Close the Definition module.

8. Go to the Home tab and Logout as Designer1. Login again as Designer2.

9. Click the Definition icon to check if you have access to the project as Designer2. A message says that the project has not been locked by you.

The Design and Setup tab’s Status pane (see image in step 10) says: “Project is locked by: Designer1”.

Before you can work on the project, ask Designer1 to unlock the project.

10. Unlock a project (System designer or Administrator)

Go to the Home tab and Logout as Designer2. Login again as Designer1.

In IGSS Master’s Design and Setup tab, click the Release lock or Unlock icon.

NB! If the user, who locked the project (here Designer1) is not available (e.g. ill or on vacation), a System Administrator can unlock the project.

11. The project is now unlocked. Before you can work on the project, you have to:

- Lock the project yourself as Designer2 before you open Definition

- IMPORTANT! Remember to Release the lock in IGSS Master when you are done working on the project and have closed the Definition module.
## Exercise 13: Create Maintenance Jobs

### Purpose
Learn how to create maintenance jobs for analog and digital objects. We will try three of the four maintenance job types:

- Periodical (q1)
- Changes (p1)
- Used time (p3)

### Duration
20 - 30 minutes.

### Task 1: Create maintenance alarm texts in Definition
Before the maintenance jobs are created in the Maintenance form, you first need to create the alarm texts we need in the Definition form.

### Step | Action
--- | ---
1. | In the **Definition** menu, click **Edit > Alarm Texts** to open the **Alarm Texts** form.
2. | In the **Alarm Texts** form, click the **New** button to open the **Edit Alarm** form.

In the **Edit Alarm** form, create alarm text for the maintenance alarm for the Periodical maintenance job type for the q1 analog object:

- In the **Alarm Text** field, enter “Calibrate flow sensor”
- In the **Acknowledge color** group, click the **Change** button and select a light red color.
- In the **Acknowledge color** group, clear the **Blink** check box
- In the **Instructions** field, enter “Use Calibrator AB 1001”
- Note the alarm number:

3. | Click the **OK** button to save the alarm text and return to the **Alarm Texts** form.
4. In the **Alarm Texts** form, click the **New** button to open the **Edit Alarm** form.

Create alarm text for the maintenance alarm for the User Time maintenance job type for the \texttt{p2} digital object:

- In the **Alarm Text** field, enter “Lubricate pump bearings”
- In the **Acknowledge color** group, click the **Change** button and select a light red color.
- In the **Acknowledge color** group, clear the **Blink** check box
- In the **Instructions** field, enter “Use the green lube tube for optimal lubrication”
- Note the alarm number:

5. Click the **OK** button to save the alarm text and return to the **Alarm Texts** form.

6. In the **Alarm Texts** form, click the **New** button to open the **Edit Alarm** form.

Create alarm text for the maintenance alarm for the Changes maintenance job type for the \texttt{p1} digital object

- In the **Alarm Text** field, enter “Visually inspect rotating parts”
- In the **Acknowledge color** group, click the **Change** button and select a light red color.
- In the **Acknowledge color** group, clear the **Blink** check box
- In the **Instructions** field, enter “Make sure you’re inspecting all rotating parts”
- Note the alarm number:

7. Click the **OK** button to save the alarm text and return to the **Alarm Texts** form.

8. Click the **Close** button to save the alarm texts and exit the form.

9. In the **Definition** menu, click **File > Check and Deploy** to save and install the project.
Before the maintenance jobs can be created, you need to ensure that the Maintenance module is running when the IGSS application is started.

**Task 2: Start Supervise and Maintenance**

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the IGSS Master, click <strong>Design and Setup &gt; System Configuration</strong> button to open the <strong>System Configuration</strong> form.</td>
</tr>
<tr>
<td></td>
<td><em>Note</em> that you need to save your project and close the Definition module before you can make changes in System Configuration.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>System Configuration</strong> form, click the <strong>Applications</strong> tab and select the <strong>Auto start in normal mode</strong> check box in the <strong>Maintenance</strong> row.</td>
</tr>
<tr>
<td>3.</td>
<td>Click <strong>File &gt; Save Project</strong> and Exit</td>
</tr>
<tr>
<td>4.</td>
<td>The <strong>Maintenance</strong> module is started automatically when the IGSS program starts.</td>
</tr>
</tbody>
</table>
Exercise 13: Create Maintenance Jobs

**Task 3: Create a Periodical maintenance job**

For the flow sensor we want to create a Periodical maintenance job that ensures that the flow sensor is calibrated every 60th day. Because we want to see the maintenance alarm right now, we create it as 2 minutes instead.

We also create a new folder for the job description.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Open the <strong>Maintenance</strong> module. Click <strong>Configuration</strong> tab &gt; <strong>New Job</strong> button.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Job type</strong> group, select <strong>Periodical</strong>.</td>
</tr>
<tr>
<td>3.</td>
<td>In the object list, type “q1” to go to the first object starting with “q1”. Select the q1 <strong>Flow water in analog object</strong>. Click <strong>OK</strong> to open the New <strong>periodical Job (q1)</strong> form.</td>
</tr>
<tr>
<td>4.</td>
<td>In the New <strong>periodical Job (q1)</strong> form, clear the <strong>Title</strong> field.</td>
</tr>
</tbody>
</table>
5. In the **Maintenance interval** group in the **Periodical interval** field, select “2” and “minutes”

6. Under **Alarm fired when job is due**, select the “Calibrate flow sensor” alarm text created in Task 1.

7. Click the **Use Alarm Text** button to insert the alarm text title as the title of this maintenance job.

8. On the **Job Description** tab, type a filename for the maintenance job description (for example, “q1_cal_sensor.txt”)

   In the input field under the **Filename** field, enter “When you calibrate the sensor, make sure you’re using Calibrator AB 1001.”

   Click the **OK** button to create the new maintenance job.

   The new maintenance job now appears in the **All Maintenance Jobs** list.

9. Edit the maintenance job to create a new sub-folder for the job description:

   a) Right-click on the q1 maintenance job and select **Edit**...

   b) In the **Job Description** tab, place the cursor in the **\Maintenance** field and click **Browse**.

   c) In the **Browse For Folder** form, scroll down to the **Maintenance** folder.

   d) Click **Make new folder** and enter a name that helps provide a good overview of descriptions for different types of maintenance jobs. For the q1 Flow water in sensor we name the new folder **Flow sensors**.
Task 4: Create a Changes maintenance job

For the p1 water pump we want to create a Changes maintenance job where we ensure that the rotating parts of the pump are visually inspected after 1,000 state changes. We also want to attach a file with additional instructions.

We don’t have time to wait for 1,000 changes, so use 5 state changes instead.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Open the Maintenance form and click Configuration tab &gt; New Job button.</td>
</tr>
<tr>
<td>2.</td>
<td>In the Job type group, select Changes.</td>
</tr>
<tr>
<td>3.</td>
<td>In the object list, type “p1“ to go to the p1 object. Select the p1 digital object. Click OK to open the New State Changes Job (p1) form.</td>
</tr>
<tr>
<td>4.</td>
<td>In the New State Changes (p1) form, clear the Title field.</td>
</tr>
<tr>
<td>5.</td>
<td>In the Maintenance interval group, in the Job due after field, enter “5”.</td>
</tr>
<tr>
<td>6.</td>
<td>In the Count on state change to (0) input field, select the OFF and ON check boxes as we want to count every change between the two states.</td>
</tr>
<tr>
<td>7.</td>
<td>In the Alarm fired when job is due field, select the “Visually inspect rotating parts” alarm text created in Task 1.</td>
</tr>
<tr>
<td>8.</td>
<td>Click the Use Alarm Text button to insert the alarm text title as the title of this maintenance job.</td>
</tr>
</tbody>
</table>
9. At the bottom of the **New State Changes Job** form, click the **File** tab.
   1) Click the **Select file...** button to open the **Open Job Link** dialog.
   2) In the **Location Field** dialog, select **All Files (*.*)** in the lower right hand corner of the dialog.
   3) Navigate to the
       
       `C:\Program Files (x86)\Schneider Electric\GSS32\V13.0\Gss\Eng`
       
       subfolder of your installation path and select the file **GetStart.pdf**.
   4) Click the **Open** button to create a link to the document.

The operator will then be able to view this manual to read the maintenance instructions. The IGSS Getting Started manual is used as an example of referring to the component manufacturer’s documentation file.

10. Click the **OK** button to create the new maintenance job.

The new maintenance job now appears in the **All Maintenance Jobs** list.

**Task 5: Create a Used time maintenance job**

For the p3 water pump we want to create a Used Time maintenance job where we ensure the water pump is lubricated after 1,000 hours of use.

We do not have time to wait for 1,000 hours, so use 2 minutes instead of 1,000 hours.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Open the <strong>Maintenance</strong> form and click <strong>Configuration</strong> tab &gt; <strong>New Job</strong> button.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Job type</strong> group, select <strong>Used Time</strong>.</td>
</tr>
<tr>
<td>3.</td>
<td>In the object list, type “p3” to help find the p3 object. Select the p3 digital object and click the <strong>OK</strong> button to open the <strong>New Used Time Job</strong> (p3) form.</td>
</tr>
<tr>
<td>4.</td>
<td>In the <strong>New Used Time (p3)</strong> form, clear the <strong>Title</strong> field.</td>
</tr>
<tr>
<td>5.</td>
<td>In the <strong>Maintenance interval</strong> group, in the <strong>Job due after</strong> field, enter “2” “minutes” In the <strong>When job completed</strong> group, select the <strong>Next job after</strong> option and enter “15” to schedule the next and subsequent maintenance jobs for 15 minute intervals after the first maintenance.</td>
</tr>
<tr>
<td>6.</td>
<td>In the <strong>States (0)</strong> input field, select the <strong>ON</strong> check box as we only want to sum the operation time when the pump is running.</td>
</tr>
</tbody>
</table>
7. In the **Alarm fired when job is due** field, select the “Lubricate pump bearings” alarm text created in Task 1.

8. Click the **Use Alarm Text** button to insert the alarm text title as the title of this maintenance job.

9. In the **Maintenance** form, click the **Help File** tab at the bottom.
   
   1) Click the **Browse** button to open the **Open Job Link** dialog.
   
   2) In the **Open Job Link** dialog, select **All Files (*.*)** in the lower right-hand corner of the dialog.
   
   3) Navigate to the `C:\Program Files (x86)\Schneider Electric\IGSS32\V13.0\Gss\Eng` subfolder of your installation path and select the file `Maintenance.chm`.

   4) Click the **Open** button to create a link to the document.

10. Click the **OK** button to create the new maintenance job.

The new maintenance job now appears in the **All Maintenance Jobs** list.

**Task 6: View, acknowledge and complete maintenance alarms**

In this last task, we’ll handle the maintenance alarms that will result from the maintenance jobs we just created.

Remember that the maintenance alarm will occur in two contexts: in the Alarm List (because we attached an alarm text) and in the Maintenance List.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>In the <strong>IGSS Master</strong>, click <strong>Home</strong> tab &gt; <strong>Alarm</strong> button to open the <strong>Active Alarms</strong> form.</td>
</tr>
<tr>
<td>2.</td>
<td>In the <strong>Active Alarms</strong> form, find and select the alarm which was originated from the maintenance job for either the q1 or p1 or p3 objects. In the workspace pane of the <strong>Active Alarms</strong> form, right-click the alarm and select <strong>Acknowledge</strong>.</td>
</tr>
</tbody>
</table>
3. In the IGSS Master, click Home tab > Maintenance button to open the Maintenance form.

Select the Due in filter and select the maintenance job you acknowledged in the previous step.

In the Maintenance form, click Configuration tab > Edit Job button to display the Job Information form and read any operator instructions.

4. Click OK to close the Job Information form when you have read the instructions.

5. In the Maintenance form, click Job Handler tab > Complete button to register successful resolution of the maintenance job.

The maintenance job will now be moved to the All Maintenance Jobs list.

6. (Optional Step – add a note). In the Maintenance job list in the Job handler tab > Maintenance Jobs due filter, select another maintenance job.

In the Job Handler tab, click Open Job Note button, enter a text in the note pane and click Add note.

Close the note pane and verify that a yellow note icon is attached to the selected maintenance job.

This exercise completes the IGSS Configuration Workshop.